Solar Eclipse Product Data Warehouse

Release 8.6.9
Legal Notices

© 2011 Epicor Software Corporation. All rights reserved. Unauthorized reproduction is a violation of applicable laws. Epicor and the Epicor logo are registered trademarks and/or registered service marks of Epicor Software Corporation in the United States and other countries. Epicor Eclipse is a trademark and/or service mark of Epicor Software Corporation. All other trademarks or service marks are the property of their respective owners and should be treated as such.

Epicor® Eclipse™ 8.6.9 Online Help System

This online help system, as well as the software described in it, is provided under license and may be used only in accordance with the terms of the license. The content provided is for informational use only and is subject to change without notice. Epicor Software Corporation assumes no responsibility or liability for any errors or inaccuracies that may be included in this documentation.

Publication Date: August 31, 2011
# Table Of Contents

Product Data Warehouse Overview................................................................. 1
  Standardizing Data in Eclipse........................................................................ 1
  Creating Nonstock Products ......................................................................... 1
  Product and Pricing Updates ........................................................................ 1
  Instant Access to Detailed Information ......................................................... 2
  Data Extraction ............................................................................................. 2
Setup Requirements for PDW............................................................................ 3
  Control Maintenance Records ....................................................................... 3
  Authorization Keys........................................................................................ 4
Creating a PDW Product Template................................................................. 5
How Data Flows in PDW Workflow ............................................................... 6
PDW from Import to Export Workflow.......................................................... 7
PDW Metadata Maintenance Overview ............................................................ 8
Defining PDW Metadata Items ....................................................................... 9
PDW Import Map Maintenance Overview ....................................................... 11
Defining PDW Import Layouts ..................................................................... 12
Solving Issues for Fixed and Delimited Fields in PDW ................................. 15
  Fixed Fields ............................................................................................... 15
  Delimited Fields ....................................................................................... 15
Mapping PDW Import Data .......................................................................... 16
Importing PDW Data Overview .................................................................... 19
  Data Source ............................................................................................... 19
  PDW Catalog ............................................................................................ 19
Previewing and Importing Data in the PDW Catalog .................................... 20
Viewing the PDW Preview Report ................................................................. 22
Importing i2 Data into the PDW Catalog ...................................................... 23
Viewing and Editing Data in the PDW Catalog ............................................. 24
Unique PDW Imports and Data Sources Overview ....................................... 26
  EDI Request IDW Catalog and FTP Request IDW Catalog ............................ 26
  FTP Request PDW Update ......................................................................... 26
Importing IDW Catalog Data into PDW ......................................................... 27
Checking Your IDW Request's Status ............................................................ 30
Using FTP Requests to Update PDW ............................................................ 31
Solar Eclipse Product Data Warehouse

PDW Data Proofing Overview ................................................................. 34
Running the PDW Data Proofing Report ............................................. 35
Defining Selection Criteria for the PDW Data Proofing Report ............ 37
PDW Merge Utility Overview ............................................................... 39
Merging PDW Records ........................................................................ 40
Searching for Matching PDW Product Records .................................. 43
Viewing the PDW to PDW Product File Merge Report ......................... 44
PDW/Eclipse Product File Sync Utility Overview ................................. 45
Syncing PDW and Eclipse Product Files .............................................. 46
Searching for Matching PDW and Eclipse Products ............................. 49
Viewing the PDW Product File Sync Report ....................................... 51
Unsyncing Products from PDW ............................................................ 52
PDW Export Overview ......................................................................... 53
Mapping PDW Data Elements to Eclipse Dictionary Items .................. 54
Creating Override Maps for PDW Product Exports .............................. 56
Mapping Multiple PDW Metadata Items to One Eclipse Dictionary Item ... 57
Mapping PDW Metadata Items to Multi-Valued or Multi-Branched Dictionary Items ... 59
Viewing Sample Data for PDW Exports .............................................. 61
Mapping PDW Price Elements to Eclipse Pricing Basis Names ............ 63
Creating an Override Map for PDW Price Exports ............................... 65
Exporting PDW Data to the Eclipse Product File .................................. 66
Editing and Verifying PDW Product Updates ...................................... 68
Verifying Price Sheets for PDW Price Updates .................................... 69
Verifying PDW Products Assigned to a Price Sheet ............................. 71
Running the PDW Price Sheet Formulas Report ................................ 72
Running Eclipse Product File Batch Update Reports for PDW .............. 73
    Update Report ............................................................................. 73
    Error Report ............................................................................. 73
Defining Fields for the PDW Mass Product Export Screen ................... 74
Exporting Mass Product Data From the PDW .................................... 75
PDW File Extract Utility Overview ..................................................... 77
Extracting PDW and Eclipse Product Data ......................................... 78
Designing an Extract for PDW and Eclipse Pricing ............................. 80
Defining Selection Criteria for a PDW and Eclipse Extract .................. 81
Downloading PDW and Eclipse Data to an ASCII Formatted File ......... 83
Table Of Contents

Filtering PDW Data .......................................................................................................................... 84
PDW Translate Statements .................................................................................................................. 85
Creating PDW Translate Statements ............................................................................................... 86
Creating PDW Convert Statements .................................................................................................. 88
Viewing All Translate and Convert Statements ............................................................................... 90
Building PDW Formulas .................................................................................................................. 91
Using PDW User-Defined Files ....................................................................................................... 92
Provided PDW User-Defined Files .................................................................................................. 94
Rebuilding Cache Records for PDW ............................................................................................... 95
  Rebuilding Price Sheet/Discount Class Cache Records ............................................................... 95
  Rebuild Zone/Sheet Cache in Meta File Utility ............................................................................ 95
Rebuilding the PDW Index ............................................................................................................... 96
Purging PDW Catalog Record History ........................................................................................... 97
Running the PDW Master Upload Utility ....................................................................................... 99
Index .............................................................................................................................................. 101
Product Data Warehouse Overview

The Product Data Warehouse (PDW) companion product is a database in which you can efficiently store, manage, and search for detailed product information. The PDW Catalog can store millions of product records, each containing an unlimited number of descriptive fields. The PDW Catalog is independent from, but fully integrated with your Eclipse Product file. As a result, you can:

- Maintain entire vendor catalogs without any effect on your system’s performance.
- Automate the task of updating your product file and pricing matrices without any manual data entry.
- Efficiently maintain product attributes for every product that you sell, or might want to sell.
- Easily add, modify or update product information without the risk of duplication.

Following are some of the key benefits of the PDW:

Standardizing Data in Eclipse

After you have created records in the PDW, you can clean up your Eclipse Product file by eliminating duplicate product records, discarding obsolete data, and standardizing your product descriptions. Record-matching logic looks at multiple data fields to match and synchronizes the elements of new and existing records.

Creating Nonstock Products

When you search for a product, the system searches the Eclipse Product file. If a match is not found, the system does a secondary search of the PDW. If the system finds a match in the PDW, you can add that product to the Product file. Since the PDW is a separate database, you can maintain an infinite number of products without affecting the overall performance of your system.

Note: When a new nonstock is brought over with PDW, any future pricing on that item will be ignored. The pricing is based on the date of the import.

Product and Pricing Updates

The PDW serves as a ready source of current product and pricing data for every product that you sell, or might want to sell. You can import electronic data into the PDW from virtually any data source in a wide variety of data formats including XML, SQL, ASCII, DBF and spreadsheets. You can upload data manually using diskettes or a CD-Rom, or electronically through EDI, FTP or HTTP. The PDW supports the ability to receive incremental product and pricing updates from industry-standard data providers such as PFMS, eDataFlex Catalog Connect, ASA Source, and the Industry Data Warehouse (IDW). Updating the pricing for products in your Product file is very easy when you export the updates from the PDW.

Integrate the imported product and pricing data with the PDW as follows:

- Define the data elements, such as vendor or catalog numbers, in PDW.
- Lay out and map the imported product data fields to the PDW data elements.
- Import the product data into the PDW.

Integrate your PDW product files with the Eclipse Product file as follows:
• Sync products in the PDW with products in the Eclipse Product file.
• Lay out and map product data elements in the PDW to matching Eclipse product file attributes.
• Export the PDW data to the Eclipse Product file.

**Instant Access to Detailed Information**

From an item in order entry, you can access the PDW to view product data not stored in your Product file, such as an image or the vendor’s installation instructions.

PDW offers full parametric search capability that helps you locate the products you need by describing them in any number of ways. You can search on virtually any identifying element, including the following:

• Manufacturer
• Short or long narrative description
• Part number
• Catalog number
• UPC
• Product family
• Dimensions
• Commodity code

Record-matching logic looks at multiple data fields to match and synchronizes the elements of new and existing records.

**Data Extraction**

The PDW also features a data extraction utility that allows you to exchange electronic product data with customers, trading partners and e-marketplaces, using industry-standard formats. That makes for simpler, faster, and more reliable communication in all directions.
Setup Requirements for PDW

Following are the control maintenance records and authorization keys used for Product Data Warehouse (PDW).

Control Maintenance Records

Set the following the control maintenance records:

PDW General

- Active PDW Version
- Allow PDW Automatic Updates
- Allow Price Line Change To PDW Items In Excluded Lines In SOE
- Domain Name for the PDW
- Ignore Products in PDW Sync With Status
- Keep Duplicate Records When Receiving Updates From The IDW
- PDW Administrator
- PDW Default Product If Not Found
- PDW Reserved Source Names
- Use Separate PDW Maps For Batch Updates And Product Imports
- Valid PDW Data Types
- Valid PDW Views

PDW Products

- Allow Price Sheet Per Qty And UOM To Change On PDW Price Update
- PDW Product Template

PDW Image Settings

- PDW Full Size Image Directory
- PDW Image Path
- PDW Images Root Directory
- PDW Meta ID For Full Size Image Path
- PDW Meta ID For Thumbnail Size Image Path
- PDW Thumbnail Size Image Directory

PDW IDW Parameters

- EDI IDW Interchange ID
• EDI IDW Member Number
• IDW FTP Site Login Name
• IDW FTP Site Login Password

**PDW WOE Parameters**
• Display PDW Products In WOE
• Setting WOE, PDW Image Priorities, IMG
• WOE PDW Catalog Search: Included/Select Separately

**Authorization Keys**
Set the following authorization keys:
• PDW.CATALOG.EDIT
• PDW.NONSTOCK.ENTRY
• PDW.PM.UPLOAD
• PDW.REINDEX.ALLOWED
Creating a PDW Product Template

When you use the PDW to create a new product, the system uses data exported from the PDW. The fields in the Product record are mapped to corresponding metadata items in the PDW Catalog. When a PDW metadata item needed to populate a field in a new product record does not contain a value, the system populates the field with a default. To define defaults, create a PDW product template, as follows:

- Create a product in Product Maintenance with a description, such as *** PDW TEMPLATE ***, that identifies the record as the PDW template. Assign a Nonstock status to the record. Set the values for the other fields to the appropriate defaults.

  **Note:** In certain cases determined by the Eclipse installer, you might set up a product template for each buy line.

- Assign the record to the PDW Product Template control maintenance record. If you do not assign a PDW product template, when the system exports data from the PDW Catalog to a new product record, any fields in the primary product file that are not mapped to a corresponding field in the PDW Catalog blank are left blank.
How Data Flows in PDW Workflow
PDW from Import to Export Workflow

Define metadata items in PDW.

Define the import layout map.

Import vendor data into PDW.

Sync PDW product records with Eclipse Product File records.

Do you want to extend or extract data?

Design an extract to export both PDW and Eclipse Product File data to an external file.

Extract both PDW and Eclipse Product File data into an external file.

Create an export map to match data from PDW to the Eclipse Product File.

Export data from PDW to the Eclipse Product File.

End
PDW Metadata Maintenance Overview

Before you can create a Product Data Warehouse (PDW), you need to define the data elements you want to store in the PDW catalog for each product. Data elements are called metadata items and include product attributes, such as the UPC code, color, vendor, list price, and weight. Metadata items are storage buckets for data.

Use Metadata Maintenance to define metadata items in the PDW.

In PDW, use metadata items when performing the following functions:

- Importing product data into the PDW. Map the fields of data being imported to corresponding metadata elements, then run the import.
- Updating your Eclipse Product File. Map the metadata item in the PDW to the corresponding dictionary item in the Product file, then run the batch update.
Defining PDW Metadata Items

Use PDW Metadata Maintenance to define metadata items, which identify the data stored in the PDW. Once defined, you can use these metadata items to import data from vendor sources into the PDW and export data from the PDW to the Eclipse Product file.

Create a metadata item for each product attribute you want to store in the PDW. You can create multiple metadata items for the same type of information. For example, the IDW provides standard price updates for all your products, but Delta has set up special pricing for your company and sends price updates on diskette. In the PDW you can create metadata items for the IDW prices and metadata items for the Delta prices.

To limit user access to metadata items, assign authorization keys to the items. For example, if you want to limit who can access the buying price of a product, assign an authorization key to that metadata item. You can assign one of the predefined authorization keys included in the Eclipse system or you can assign a user-defined authorization key.

To define a metadata item:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW Meta Maintenance to display the PDW MetaData Maintenance window.
2. In the Key Number field, enter New and click Create New to define a new item.
   The system assigns a unique key number to new metadata item.
3. In the Description field, enter the description of the data element, such as TS UPC for the Trade Service UPC number or Ven UPC for a vendor UPC number.
4. In the Length field, enter the number of characters across the screen that you want this metadata item to occupy.
   Note: We recommend that you enter the same number of characters that the Eclipse dictionary item to which you will map this element occupies.
5. In the Justify (Affects Eterm only) field, select either Justify Left, Justify Right, or None to indicate whether this metadata item is right or left justified within its field.
6. Select the Index check box, to index this metadata item for product searches.
   For example, you can search for a product using its UPC number or description, so flag these elements as indexed items.
7. Select the This meta item is part of the description check box to indicate this metadata item is part of the record description.
   Vendors can break their product description data into multiple data elements, such as manufacturer ID, product type, and product ID number. You can combine these to create a complete record description.
8. To require users to be authorized to view or edit this metadata item, do the following:
   • In the Authorization Key Required field, enter the required authorization key. The key can be user-defined or one of the predefined Eclipse authorization keys.
   • If the authorization key has multiple levels, in the Authorization Levels field, enter the level of authorization that users must be assigned to view this metadata item.
9. Select the **File Validation** check box to have this metadata item populate a user-defined file for validation purposes.
   - In the File field, enter the file name to which you want to import this metadata item.
   - Select the Display in PDW Data Viewer check box to indicate you want the values stored in the user-defined file to display in the PDW Data Viewer.

10. If you included this metadata item in the record description, in the **Sort Order** field, enter the order in which this portion of the description displays with respect to the other metadata items that create the record description.
    For example, if multiple metadata items create the product description, then assign sort order 1 to the metadata item that displays first, 2 to the metadata item that displays second, and so on.

11. Select the **Display in WOE** check box to display this metadata item in the technical specifications in Web Order Entry.

12. Select the **Index in WOE Searches** check box to index this metadata item for product searches in Web Order Entry.
    **Note:** We recommend that you leave this field deselected. If you select this field your system can slow down considerably. Select this field only if you are sure you need this metadata item indexed in Web Order Entry.

13. In the **Data Type** field, select one of the following to identify metadata items as types when matching items in the PDW Catalog:
    - **UPC** - Identifies this item as an 11-digit UPC code. If the item you are defining is a 12-, 13-, or 14-digit UPC code, assign the **Unique Key** type.
    - **Unique Key** - Identifies this item as a unique key.
    - **Price** - Identifies this item as pricing data.
    - **Web URL** - Identifies this item as an Internet address that points to a web site.
    - **Media URL** - Identifies this item as an Internet address that points to the location containing an image of the product.

14. Save your changes and exit the window.

**More Options When Defining PDW MetaData Items**
The PDW MetaData Maintenance window also offers the following options:

<table>
<thead>
<tr>
<th>To..</th>
<th>Select this menu option...</th>
</tr>
</thead>
<tbody>
<tr>
<td>rebuild all indexes containing this metadata item.</td>
<td><strong>File &gt; Re-Index</strong></td>
</tr>
<tr>
<td></td>
<td>You must be assigned a high enough level of</td>
</tr>
<tr>
<td></td>
<td>authorization of the PDW.REINDEX ALLOWED</td>
</tr>
<tr>
<td></td>
<td>authorization key to rebuild indexes.</td>
</tr>
</tbody>
</table>
PDW Import Map Maintenance Overview

Before you can import data from electronic files into the Product Data Warehouse (PDW), you need to define the layout of the import record and then map each field in the layout to a metadata item in the PDW.

Use Import Map Maintenance to perform the following tasks:

- Defining the layouts of the electronic files you use to populate the PDW.
- Mapping the imported fields of data to the associated metadata items in the PDW.

You only need to perform this setup once for each source file before importing the data into the PDW. Each time you import data from a designated source, the system uses the corresponding map. You can edit import maps, as needed.

Use the following screens to complete the layout and mapping functions for importing data:

- PDW Import File Layout - Use to define the import layout of data.
- PDW Translation Table - Use to translate entire fields of data.
- PDW Import Map Maintenance - Use to name and map data.
- PDW Conversion Table - Use to convert individual words in a field.
Defining PDW Import Layouts

To import data from electronic files into the PDW, you need to define the record layout of these files for the system.

Use the Import File Layout screen to define a layout ID for the record, describe the fields in the record, and choose the record type. The record type can be:

- **Fixed** - The record has fixed-length fields.
- **Delimited** - The record has variable-length fields separated by delimiters.

For each file layout, define field names, positions, and format. You can also translate any field to another value using the **Translate** hot key.

**To define an import layout:**

1. From the **Tools > Product Data Warehouse (PDW)** menu, select **PDW Import Map Maintenance** to display the PDW Import Maintenance screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the **Layout ID** field, enter an alphanumeric name of up to 10 characters to identify the file layout.

3. At the **NEW** prompt, press **Enter** to indicate that you are defining a new layout.

   The system displays the PDW Import File Layout screen and populates the **Layout ID** field with the name you entered on the PDW Import Maintenance screen.

4. In the **Description** field, enter a name to describe the file you are importing.
   
   **Note:** When you search for the layout during data import, this layout description displays to the right of the import ID.

5. In the **Record Type** field, press **F10** and select Fixed or Delimited.

   Your selection in this field determines the entries and fields on the remainder of the screen.

6. If the record type is **Fixed**, complete the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Identifier</td>
<td>An alphanumeric name that identifies the field for the imported data.</td>
</tr>
<tr>
<td><strong>Note:</strong> You cannot use &quot;Key&quot; as a data identifier. This word is reserved for Eclipse internal use only.</td>
<td></td>
</tr>
<tr>
<td>Start Pos</td>
<td>The beginning location for the record data. This location follows the last characters of header information.</td>
</tr>
<tr>
<td></td>
<td>For example, if the header has 50 characters and you want to begin importing data immediately after the header, enter 51 to begin the record at the first position after the header.</td>
</tr>
<tr>
<td>Record Length</td>
<td>The number of characters in one record.</td>
</tr>
<tr>
<td></td>
<td>For example, enter 1000 if each record contains 1000 characters.</td>
</tr>
</tbody>
</table>
For each field you want to import, complete the following columns:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>The starting position in the record from where the system pulls the information for the designated field. For example, enter 1 for the system to pull information from the beginning position.</td>
</tr>
<tr>
<td>Length</td>
<td>The number of characters in the designated field. For example, enter 50 for the system to pull the information from positions 1-50.</td>
</tr>
</tbody>
</table>
| Format | Press F10 and select one of the following formats for the field entry if you want to assign a format to the field's entry:  
- **MR#** – Masks right the indicated number of decimal positions. For example, if you are importing the numbers 236 to represent the dollar amount $2.36, select MR2 to insert a decimal point two positions to the right of the ending digit.  
- **D2/ D4/** – Masks the indicated number of spaces for dates. |

**Note:** The **Pos** column does not apply to the Fixed format.

7. If the record type is **Delimited**, complete the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Data Identifier | An alphanumeric name that identifies the field for the imported data.  
**Note:** You cannot use "Key" as a data identifier. This word is reserved for Eclipse-use only. |
| Delim Char | One of the following field delimiters:  
- The ASCII character.  
- A caret (^) followed by the ASCII number of the character.  
- Tab for the tab character. |
| Envelope Char | If the text in each field is enclosed by an envelope character, such as quotation marks, enter the character in this field. |

For each field you want to import, complete the following columns:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pos</td>
<td>The field's position within the record.</td>
</tr>
</tbody>
</table>
| Format | Press F10 and select one of the following formats for the field entry if you want to assign a format to the field's entry:  
- **MR#** – Masks right the indicated number of decimal positions. For example, if you are importing the numbers 236 to represent the dollar amount $2.36, select MR2 to insert a decimal point two positions to the right of the ending digit.  
- **D2/ D4/** – Masks the indicated number of spaces for dates. |

**Note:** The **Start** and **Length** columns do not apply to the Delimited format.

8. To create a translate statement for a data identifier in the layout, select the data identifier and use the **Translate** hot key.

9. Press **Esc** to save the layout and return to the PDW Import Maintenance screen.
You can now map the data import layout to the PDW.
Solving Issues for Fixed and Delimited Fields in PDW

You may experience some common problems when you define your electronic files' fields. For the following problems, use the suggested solutions.

**Fixed Fields**

For files with headers that you cannot remove but you do not want to import, define the start position one character after the last character position of the header.

For example, if the header ends at position 128, enter 129 for the first field.

**Delimited Fields**

The following three problems are common when you use delimited fields:

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are using quotation marks (&quot;) to represent inches in Microsoft Excel, Excel tries to treat these characters as enveloping characters.</td>
<td>Use Microsoft Access to save files as text (TXT) when some fields include quotation marks.</td>
</tr>
<tr>
<td>If the data in a .csv file is comma (,) delimited and some data elements already include commas, the system incorrectly separates the data.</td>
<td>Use quotation marks (&quot;) as the enveloping character instead.</td>
</tr>
<tr>
<td>If a quotation mark enveloping character causes the data to split incorrectly, then the fields within the files include commas and quotation marks.</td>
<td>Change the file to a <strong>Tab</strong> delimited text (TXT) file and remove the quotation marks as enveloping characters.</td>
</tr>
</tbody>
</table>
Mapping PDW Import Data

Use the PDW Import Maintenance screen to map your electronic data to the associated metadata elements in the Product Data Warehouse (PDW) Catalog. Import mapping works by identifying all records with unique layout keys, and then mapping each field of a record to a pre-defined PDW metadata item.

The system uses the layout key to merge or match the items you are importing to those items that have been provided by another data provider to prevent duplicates in the PDW Catalog. In addition, for any items that did not match the layout key, the system make an additional pass through the data to determine if the initial no match items match to the secondary key.

Do not merge metadata values from a primary data source with a vendor disk or some other data source. Instead create metadata items specific to each primary data source, with the exception of vendor disks.

For vendor-provided disks, you can share a set of metadata items among all vendor disks because you will only receive one version of each vendor disk per load. If you create a metadata item of Disk Vendor Name and populate it from two vendor disks, such as Sylvania and Leviton, only the Sylvania items are affected by the Sylvania disks and only the Leviton items are affected by the Leviton disks. The integrity of the data is protected.

You can also define any pricing zones that may exist for products. Pricing zones hold multiple price sheets that apply to one product distributed across multiple branches. You define pricing zones when a vendor sends multiple disks for the same product. On each of these disks are different pricing sheets for the product that you distribute from multiple branches. Pricing zones let you keep the product in the same price line but still assign the correct pricing sheet to it. Set up pricing zones by:

- Defining a price sheet within the system for each branch that contains the product.
- Defining all sheets that belong to one zone.

To map data from an electronic database into the associated metadata elements:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW Import Map Maintenance to display the PDW Import Maintenance screen.
   - Note: If prompted, log on to the character-based system.

2. In the Layout ID field, enter a name of up to 10 characters to assign this file's layout.

3. At the NEW prompt, press Enter to indicate that you are defining a new layout.

4. Define the import layout for the record on the PDW Import File Layout screen and return to the PDW Import Maintenance screen by pressing Esc.
   - The system populates the Layout ID and Desc fields with information from the PDW Import File Layout screen.

5. In the Layout Key field, enter a unique number, such as a UPC number, Manufacturer Catalog or Part number, or an NAED number, to define the key to the file.

6. In the Secondary Key field, enter a unique number, such as a UPC number, Manufacturer Catalog or Part Number, or an NAED number the system uses to match any items that did not match the key you entered in the Layout Key field.

7. In the UPC Format (Y/N) field, enter Y or N to indicate whether the UPC trimming logic that follows should apply to the Key.
• If the UPC is 12 digits long, the last character, which is a check digit, is trimmed.
• If the UPC is 13 digits long, the first and last characters, are trimmed.
• If the UPC is 14 digits long, the first 2 characters and the last character are trimmed.

The system formats all UPC codes to 11 digits, but you can store all UPC numbers.

If you want to store UPC numbers with the package quantity digits and check digits, do the following:
• Create a separate MetaData item named Full UPC.
• Index and flag this element as a unique ID data type, but do not flag it as a UPC data type.
• Map the same data element into a MetaData item named UPC and define that MetaData element as a UPC data type.

This process gives you ultimate flexibility to use the UPC for matching/merging/syncing. It also uses the UPC + check digit/package quantity identifier for matching.

**Note:** Do not enable UPCs to be branch-specific because PDW does not support this function. If you enable UPCs to be branch-specific, we cannot guarantee that UPCs in PDW will work correctly.

7. In the **Pricing Zone** field, enter a pricing zone if you need to define one for the map to use. You can identify the pricing zone by entering either free-form text or a data identifier defined on the current map.

8. In the **Pricing Sheet** field, if you entered a pricing zone, enter the sheet within the zone that the map needs to use for pricing elements.

9. In the **Data Identifier** field, import all of the metadata elements defined in Import File Layout by using the **Add All** hot key.

10. In the **PDW MetaData Item** field, enter the metadata item in the PDW Catalog to which you want the data identifier mapped.

   **Note:** You can create metadata items from the Import Map Maintenance screen by entering **New** in the **PDW MetaData Item** field. This displays the PDW MetaData Maintenance screen where you can create the item. Press **Esc** to return to the Import Map Maintenance screen. However, we recommend that you create PDW metadata items in advance.

11. Press **Esc** to save changes and exit the screen.

**More Options for Mapping Import Data**

The PDW Import Maintenance screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout</td>
<td>Displays the PDW File Import Layout screen where you can edit the layout information.</td>
</tr>
<tr>
<td>Meta</td>
<td>Displays the PDW MetaData Maintenance screen. Use this screen to define the data elements in your PDW Catalog.</td>
</tr>
<tr>
<td>Copy</td>
<td>Displays a prompt where you can enter a new Layout ID for which you want to copy the currently displayed layout.</td>
</tr>
<tr>
<td><strong>Hot Key</strong></td>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Delete Layout</td>
<td>Deletes the currently displayed layout. The system prompts you to confirm the deletion.</td>
</tr>
<tr>
<td>Convert</td>
<td>Displays the PDW Conversion Table screen, where you can create convert statements.</td>
</tr>
<tr>
<td>Expand</td>
<td>Displays the complete metadata item descriptions for the selected line.</td>
</tr>
</tbody>
</table>
Importing PDW Data Overview

Importing data is the final step in importing product and pricing data into the Product Data Warehouse (PDW) Catalog.

Before you can import data into the PDW, you need to complete the following tasks:

- Define metadata items.
- Define the import map layout.
- Map the import layout to metadata items in the PDW.

Data Source

During import, PDW creates product records for all of your data sources in the following way.

The table below represents your data source:

- The top row holds the five data elements defined for this data source.
- Each column below the first row contains the data element values for each product from your data source.
- Every row after the first row then equals one product record.

<table>
<thead>
<tr>
<th>Short Name</th>
<th>Vendor Desc</th>
<th>UPC</th>
<th>Cat#</th>
<th>List Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lev</td>
<td>Receptacle</td>
<td>123456789012</td>
<td>5252i</td>
<td>6.36</td>
</tr>
<tr>
<td>Syl</td>
<td>IPS Elbow</td>
<td>345678901234</td>
<td>646372e</td>
<td>10.00</td>
</tr>
<tr>
<td>ABC</td>
<td>Pipe Cmpnd</td>
<td>098765432109</td>
<td>333388</td>
<td>5.55</td>
</tr>
</tbody>
</table>

PDW Catalog

When you run an import, the PDW Catalog reads your data source, one record at a time, and then assigns each record a product record ID.

The table below then represents the PDW Catalog upon completion of the import.

- The first column contains the assigned product record IDs.
- Each row is one product record.

<table>
<thead>
<tr>
<th>Product Record ID</th>
<th>Short Name</th>
<th>Vendor Desc</th>
<th>UPC</th>
<th>Cat#</th>
<th>List Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>508394</td>
<td>Lev</td>
<td>Receptacle</td>
<td>123456789012</td>
<td>5252i</td>
<td>6.36</td>
</tr>
<tr>
<td>508395</td>
<td>Syl</td>
<td>IPS Elbow</td>
<td>345678901234</td>
<td>646372e</td>
<td>10.00</td>
</tr>
<tr>
<td>508396</td>
<td>ABC</td>
<td>Pipe Cmpnd</td>
<td>098765432109</td>
<td>333388</td>
<td>5.55</td>
</tr>
</tbody>
</table>

You can use the Preview Report to view each new record.
Previewing and Importing Data in the PDW Catalog

Use the PDW Data Import Utility to preview import data from your external sources and create or update records in the Product Data Warehouse (PDW) Catalog.

Run the utility two times, as follows:

- Run the utility once to create a preview report that shows the data as it will display in the PDW Catalog.
- After you review and approve the report, run the utility again to create and update the PDW records.

To preview and import data into the PDW Catalog:

1. From the Tools > Product Data Warehouse (PDW) > PDW Data Imports menu, select PDW Data Import Utility to display the PDW Data Import Utility screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Import Map ID field, enter the map ID you want to import.
   
   The system populates the Key to Import field with the Layout Key you assigned when you created the map.

   The system populates the Key to Import field with the Layout Key you assigned when you created the map.

   Note: If you do not correctly enter a matching metadata item and enter Y in the Allow New Item Creation field, the system uses this imported data to create a new item in the PDW Catalog.

3. In the Import Date Stamp field, enter the date you want this data to be stamped as effective in the PDW Catalog.

   For example, if you are importing new pricing information on 12/01/01, but the data is not effective until the new year, enter 01/01/02 as the Import Date Stamp to mark the information as inapplicable until the correct date.

4. In the Update Type field, press F10 and select one of the following:
   
   - Preview - Displays the data as it will display after it is imported into the PDW Catalog without actually importing it.
   
   - Update - Imports the data into the PDW Catalog without a preview.

   Note: Always preview your data before updating the PDW Catalog.

5. If you are running a preview, in the Number of Bytes to Preview field, enter the number of bytes that will process at least 10 records.

6. If you are importing from vendor diskettes, in the Number of Update Disks, enter the number of disks.

7. In the Allow New Item Creation field, enter Y to create a new item in the PDW Catalog if the system does not find an existing matching product. Enter N to discard the import data.
8. Use the following hot keys, as needed:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Import Map</td>
<td>Displays the import map layout.</td>
</tr>
<tr>
<td>Filter</td>
<td>Displays the Filter Builder screen, where you can build a filter for selecting the</td>
</tr>
<tr>
<td></td>
<td>metadata items to update. Use a filter when you use a catalog number that might not be</td>
</tr>
<tr>
<td></td>
<td>unique to only the vendor providing the data.</td>
</tr>
</tbody>
</table>

9. Use one of the following hot keys to run the import:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import From DOS</td>
<td>Imports data from DOS files. At the prompt, enter the DOS pathname to import the file.</td>
</tr>
<tr>
<td></td>
<td>• To import one file within the directory, enter the entire pathname including the file</td>
</tr>
<tr>
<td></td>
<td>name.</td>
</tr>
<tr>
<td></td>
<td>For example, enter c:/directory/filename.filetype.</td>
</tr>
<tr>
<td></td>
<td>• To import all files within the directory, such as when a vendor provides each line in</td>
</tr>
<tr>
<td></td>
<td>a separate .txt file, enter an asterisk (*) in place of the individual file name.</td>
</tr>
<tr>
<td></td>
<td>For example, enter c:/directory/*.</td>
</tr>
<tr>
<td></td>
<td>This pathname instructs the system to import every file in the directory.</td>
</tr>
<tr>
<td></td>
<td>Note: When you import data from a DOS file, you cannot use your application until the</td>
</tr>
<tr>
<td></td>
<td>system has completed loading the data.</td>
</tr>
<tr>
<td>Import From UNIX</td>
<td>Imports data from UNIX files, such as product data from your FTP file. At the prompt,</td>
</tr>
<tr>
<td></td>
<td>enter the UNIX pathname to run the import.</td>
</tr>
<tr>
<td></td>
<td>• To import one file within the directory, enter the entire pathname including the file</td>
</tr>
<tr>
<td></td>
<td>name.</td>
</tr>
<tr>
<td></td>
<td>For example, enter /u2/pdw/elec/trade.dat.</td>
</tr>
<tr>
<td></td>
<td>• To import all files within the directory, such as when a vendor provides each line in</td>
</tr>
<tr>
<td></td>
<td>a separate .txt file, enter an asterisk (*) in place of the individual file name.</td>
</tr>
<tr>
<td></td>
<td>For example, enter /u2/pdw/elec/*.</td>
</tr>
<tr>
<td></td>
<td>This pathname instructs the system to import every file in the directory.</td>
</tr>
</tbody>
</table>

10. Press **Esc** to run the utility and exit the screen.

- If you run the utility in Preview mode, the system generates the Preview Report and places it in your Hold file.
- If you run the utility in Update mode, the system updates the Product file. The system does not produce a report.
Viewing the PDW Preview Report

The first time you run the PDW Import Utility, use the Preview Report to view how the data from your data source will populate the Product Data Warehouse (PDW) Catalog. When you run the utility in Preview mode, the system places the report in your Hold file.

On the report, each product record populates one row. The product record ID precedes the product data.

As you review the preview report, be aware of the following:

The report shows that x number of items were imported. The x number varies depending on the number of bytes and width of the imported file bins. Do not be alarmed when you see 27 items on the first load and eight items on the next load.

When importing from DOS, if you do not remove column headers from a .csv or .txt file, the first item populates with all of the column headers from the data source. So remove column headers on .csv and .txt files.

The report displays one of the following messages:

- **Found match data will map to** - Indicates that this data already exists in the PDW Catalog. You should receive this message if you are attempting to match to existing data.

- **No match found will map to** - Indicates that this data is new to the PDW Catalog. You should receive this message if you are not attempting to match to existing data.

**To view the PDW Preview Report:**

1. Access your Hold file in one of the following ways:
   - From the System > Printers menu, select Your Hold Entries.
   - From any screen in Eclipse, press Shift-F2.

2. Select the preview report and use the View hot key.
Importing i2 Data into the PDW Catalog

If you are using eDataFlex Catalog Connect from i2 Technology, you can take advantage of a specially designed i2 data import utility that formats and maps the data for you.

To import i2 EDATA FLEX Relational Tables into the Product Data Warehouse (PDW) Catalog, use the i2 Data Import Utility instead of the PDW Data Import Utility. i2 data's format is unique and Eclipse has designed a separate way to import the i2 data. You need to schedule the import.

Before you run the utility, load the i2 data into a system directory. You do not need to define the data layout or map. The i2 Data Import Utility formats and maps the data to the PDW Catalog.

To import i2 data into the PDW catalog:

1. From the Tools > Product Data Warehouse (PDW) > PDW Data Imports menu, select I2 Data Import Utility to display the I2 Update of PDW Catalog screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Data Sub-Directory field, enter the sub directory holding the i2 data.

3. In the Load Date field, enter the date you want this data to load and be marked as effective in the PDW Catalog.

   For example, if you are importing new pricing information on 12/01/01, but the data is not effective until the new year, enter 01/01/02 as the Load Date to mark the information as inapplicable until the correct date.

4. In the Number of Threads field, change the number of concurrent processes that will load the i2 data, as needed.

   Note: We recommend that you use the default in this field unless you are experiencing performance issues. Contact your PDW installer if you are experiencing performance issues.

5. Use one of the following hot keys to import the data and exit the screen:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schedule</td>
<td>Displays the Phantom Scheduler, where you can schedule the import.</td>
</tr>
<tr>
<td>Begin</td>
<td>Runs the import immediately.</td>
</tr>
</tbody>
</table>
Viewing and Editing Data in the PDW Catalog

Use the PDW Data Viewer to view and edit the data stored for each product record in the Product Data Warehouse (PDW) Catalog. Enter the product and the import map or import date for which you want to view data.

You can also view the information stored within each product field, the dictionary item to which each product field is mapped, and the date each product update takes effect.

You can edit, delete, and unsync product information stored in the PDW Catalog using the PDW Data Viewer, if you are assigned the PDW.CATALOG.EDIT authorization key. You can also access the MetaData Maintenance screen to re-index your metadata items.

To view and edit data in the PDW Catalog:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW Data Viewer to display the PDW Data Viewer window.

2. In the PDW Catalog ID field, enter the product ID or indexed metadata item for the product you want to view.

The system lists each data element stored in the PDW Catalog for the designated product. By default the system displays the metadata items associated with all maps and the values for the current date. The following table describes the information displayed for each data element:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validated Info</td>
<td>The following validation characters flag the metadata item as one of the following types:</td>
</tr>
<tr>
<td></td>
<td>• * - Parametric.</td>
</tr>
<tr>
<td></td>
<td>• ! - User-defined file data.</td>
</tr>
<tr>
<td></td>
<td>• i - Indexed.</td>
</tr>
<tr>
<td>PDW Field Description</td>
<td>The metadata item description. A single PDW record can contain metadata items defined for multiple data providers or vendor disks.</td>
</tr>
<tr>
<td>PDW Data</td>
<td>The value stored in the metadata item.</td>
</tr>
</tbody>
</table>

3. To edit the PDW data, double-click in the PDW Data field, make your data changes, and click Save Changes.

More Options When Viewing and Editing PDW Catalog Data

When viewing PDW Catalog data, you can refine or expand the data you are viewing using the following fields and buttons:

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>display the import date and the dictionary item to which the PDW is mapped</td>
<td>From the Options &gt; Change View menu, select Extended.</td>
</tr>
<tr>
<td></td>
<td>To return back to the original view, select Options &gt; Change View &gt; Default.</td>
</tr>
<tr>
<td>To...</td>
<td>Do this...</td>
</tr>
<tr>
<td>---------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>select the import map for which to display the data elements</td>
<td>In the View field, select the import map. Select All to view the data elements associated with all import maps.</td>
</tr>
<tr>
<td>change the date for which to view the PDW data</td>
<td>In the PDW Date field, select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• Current - Displays only the current update information for the product.</td>
</tr>
<tr>
<td></td>
<td>• All - Displays all updates for the product.</td>
</tr>
<tr>
<td></td>
<td>• Individual dates - Displays updates listed by date.</td>
</tr>
<tr>
<td>define the metadata elements in the PDW Catalog</td>
<td>Select the PDW item in the list and then select the View &gt; PDW MetaData Maintenance menu option.</td>
</tr>
<tr>
<td>delete an item from the PDW Catalog</td>
<td>select the item you want to delete and click Delete PDW Item.</td>
</tr>
<tr>
<td></td>
<td>Note: You must be assigned the PDW.CATALOG.EDIT authorization key to delete items from the PDW Catalog.</td>
</tr>
<tr>
<td>display the product record for the PDW Catalog item</td>
<td>select the item you want to display and click Open Product Maintenance.</td>
</tr>
<tr>
<td></td>
<td>This button is only active when the product is synced to a record in the Eclipse Product file.</td>
</tr>
<tr>
<td>to break the connection between a PDW Catalog item and the Eclipse</td>
<td>select the item you want to unsync and click Unsync PDW Item from Product.</td>
</tr>
<tr>
<td></td>
<td>This button is only active when the product is synced to a record in the Eclipse Product file. You must be assigned the PDW.CATALOG.EDIT authorization key to unsync products.</td>
</tr>
<tr>
<td>launch your web browser for items that point to images</td>
<td>select the View &gt; Open Web Link menu option. Use this option to test your path mapping during implementation.</td>
</tr>
</tbody>
</table>
**Unique PDW Imports and Data Sources Overview**

The Product Data Warehouse (PDW) Catalog accepts imports from generic flat files and IDW data files using either Electronic Data Interface (EDI) or File Transfer Protocol (FTP) rather than relying solely on vendor disks.

Use one of the following unique import utilities to import FTP or IDW data.

**EDI Request IDW Catalog and FTP Request IDW Catalog**

Use the EDI Request IDW Catalog or FTP Request IDW Catalog utilities to import IDW data, with the following advantages:

- Both EDI and FTP Requests perform the data layout and mapping, so that you do not need to create an import map for IDW data.
- EDI completes the import for you. Indicate from where EDI should pull the data. You must manually import data when you use FTP.
- You can track your request for data to IDW from either the IDW web site or your FTP directory.
- You import all of your data over the Internet, so vendor disks are not needed.

**FTP Request PDW Update**

Use the FTP Request PDW Update utility to automatically download and import generic flat file or IDW data directly to the PDW Catalog, unzipped files, and define a directory to which to download data if you do not want to automatically import the data into the PDW Catalog.

**Important:** Use the FTP Request PDW Update utility in place of the EDI Request IDW Catalog or FTP Request IDW Catalog utilities to more easily download and import vendor data into the PDW Catalog.
Importing IDW Catalog Data into PDW

Use the IDW Importing tools in Product Data Warehouse (PDW) to import IDW Product Catalog data, as it has a unique format. There are two different ways to import IDW data into the PDW Catalog. You can use either EDI Request IDW Catalog or FTP Request IDW Catalog. Both complete the data layout and mapping for you, but the EDI also imports the data while you must manually import data when using FTP.

When you first import IDW using EDI or FTP, refresh the data for all manufacturers and all views. To schedule a complete refresh for EDI:

1. Schedule the request for early Thursday morning around 12:00 a.m.
2. Schedule EDI to begin checking your mailbox at least hourly, starting around 4:00 a.m.

To schedule a complete refresh for FTP:

1. On Thursday morning, schedule a request.
2. On Friday early morning around 12:05 a.m., schedule a get.

   Note: The IDW tracks all of your updates and knows which data needs to be transmitted to you.

---

**Important:** Use the FTP Request PDW Update utility in place of the EDI Request IDW Catalog or FTP Request IDW Catalog utilities to more easily download and import vendor data into the PDW Catalog.

---

To receive an update from the IDW Product Catalog using an EDI 832-R1 request:

1. From the Tools > Product Data Warehouse (PDW) > PDW Update Requests menu, select EDI Request IDW Catalog to display the IDW EDI Product Catalog Request screen.

   Note: If prompted, log on to the character-based system.

2. In the Request Type field, select one of the following:
   - Changes - Receives only the data that has changed since the date of your last request.
   - Refresh - Receives all the data, whether or not it has changed.

3. In the Views field, select one or all of the following:

<table>
<thead>
<tr>
<th>View</th>
<th>To receive...</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1</td>
<td>IDW A1 View (Vendor Data).</td>
</tr>
<tr>
<td>B1</td>
<td>IDW B1 View (Product Data).</td>
</tr>
<tr>
<td>B4</td>
<td>IDW B4 View (Product Packaging Data).</td>
</tr>
<tr>
<td>B5</td>
<td>IDW B5 View (Price Data).</td>
</tr>
</tbody>
</table>

4. In the Vendors field, indicate if you want to receive an update from:
   - All vendors for which you are authorized by leaving the default entry.
• Specified vendors by using the **Choose Vendors** hot key to display the IDW Vendor IDs screen. Enter the vendors from whom you want to receive updates on this screen. Press **Esc** once you have entered all necessary vendors.

5. Use one of the following hot keys to run the update and exit the screen:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
</table>
| Schedule | Displays the Phantom Scheduler screen so you can schedule when and how often the currently displayed request transmits. Once you have completed the first refresh, we recommend that you schedule requests for:  
• Weekly updates for your primary manufacturers on Thursdays.  
• Weekly, bimonthly, or monthly updates for your secondary manufacturers on the weekends.  
• Total refreshes for primary manufacturers quarterly.  
• Total refreshes for secondary manufacturers annually. |
| Generate | Transmits the currently displayed request. |

**To import IDW Product Catalog data using an FTP request:**

1. From the **Tools > Product Data Warehouse (PDW) > PDW Update Requests** menu, select **FTP Request IDW Catalog** to display the IDW FTP Product Catalog Request screen.

   **Note:** If prompted, log on to the character-based system.

2. In the **Function** field, enter one of the following:

   • **Request** - IDW posts the data to the FTP site.  
   • **Get** - Imports the IDW data into PDW Catalog.

   **Note:** When you run a Get function, the system includes all data from the file. So you do not need to indicate what information to bring into the PDW Catalog.

3. In the **Request Type** field, select one of the following:

   • **Changes** - Receives only the data that has changed since the date of your last request.  
   • **Refresh** - Receives all the data, whether or not it has changed.

4. In the **Views** field, select one or all of the following:

<table>
<thead>
<tr>
<th>View</th>
<th>To receive...</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1</td>
<td>IDW A1 View (Vendor Data).</td>
</tr>
<tr>
<td>B1</td>
<td>IDW B1 View (Product Data).</td>
</tr>
<tr>
<td>B4</td>
<td>IDW B4 View (Product Packaging Data).</td>
</tr>
<tr>
<td>B5</td>
<td>IDW B5 View (Price Data).</td>
</tr>
</tbody>
</table>

5. In the **Vendors** field, indicate if you want to receive an update from:

   • **All** vendors for which you are authorized.
• Specified vendors by using the **Choose Vendors** hot key to display the IDW Vendor IDs screen. Enter the vendors from whom you want to receive updates on this screen. Press **Esc** once you have entered all necessary vendors.

6. Use one of the following hot keys to run the update and exit the screen:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
</table>
| **Schedule** | Displays the Phantom Scheduler screen so you can schedule when and how often the currently displayed request transmits. Once you have completed the first refresh, we recommend that you schedule requests for:
  • Weekly updates for your primary manufacturers on Wednesdays.
  • Weekly, bimonthly, or monthly updates for your secondary manufacturers on the weekends.
  • Total refreshes for primary manufacturers quarterly.
  • Total refreshes for secondary manufacturers yearly. |
| **Generate** | Transmits the currently displayed request. |
Checking Your IDW Request's Status

You can check on your request after you post it to IDW. You can check this status on both the IDW web site and in your FTP directory.

To check the process of your request on the IDW web site:
1. Access the IDW web site by entering https://nteagle02.triad.com in your browser.
2. Log in with your user name and password.
3. Select option three, View Logs.
   If IDW has processed your request, the display shows a log entry with the date and time it was processed.
4. After viewing the logs, exit the browser.

To check for IDW files in your FTP directory:
1. From the System menu, select TCL to display the TCL screen.
   Note: If prompted, log on to the character-based system.
2. At the ; prompt, enter sh to shell down from TCL.
3. At the $ prompt, enter ftp -nv gate data port (this entry is unique to your system) to connect to your FTP directory.
   The screen displays Connected to gate. 220 WinProxy (Version 2.1 R2g) ready.
4. At the ftp> user prompt, enter username@nteagle02.triad.com to log in to the FTP site.
5. At the Ex ftp> user prompt, enter yourlogin@nteagle02.traid.com yourlogin###.
6. At the next ftp> prompt, enter ls -l to direct the FTP directory to list all files.
   • If EDIDATA.OUT displays, then the request is waiting for IDW to process it.
   • If tranfile.### displays, then the update is either waiting to be picked up and imported into the PDW Catalog or currently being built.
7. At the next FTP> prompt, enter bye to log off the FTP site.
8. At the $ prompt, enter exit to leave TCL.
Using FTP Requests to Update PDW

Use the FTP Request PDW Update utility to do the following using File Transfer Protocol (FTP):

- Automatically download and import generic flat file or IDW data directly to the PDW Catalog.
- Unzip zipped generic flat files or IDW data files.
- Define a directory to which to download generic flat files or IDW data. Define this directory in the Local Path For PDW FTP Files control maintenance record.
- Schedule downloads and imports for regularly updated vendors.
- Download multiple generic flat files or IDW data files into the directory defined in the Local Path For PDW FTP Files control maintenance record. The system cannot import multiple files into the PDW Catalog. Instead it downloads the files into the defined directory, and you can then manually import each file into the PDW Catalog.

**Important:** Use the FTP Request PDW Update utility in place of the EDI Request IDW Catalog or FTP Request IDW Catalog utilities to more easily download and import vendor data into the PDW Catalog. Unlike the two step FTP Request IDW Catalog, this process is only one step because you have the option of directly importing the data into the PDW Catalog.

To use FTP Requests to update the PDW Catalog:

1. From the Tools > Product Data Warehouse (PDW) > PDW Update Requests menu, select FTP Request PDW Update to display the FTP Request PDW Update screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the **Import Map** field, enter the import map ID for which to download and import the generic flat file or IDW data.
   
   **Note:** The system saves the FTP Request PDW Update data entered for the import map ID so that you do not have to re-enter the data for future downloads and imports.

3. Complete the following fields, as needed:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FTP Address</td>
<td>FTP site address for the data update.</td>
</tr>
<tr>
<td>Directory</td>
<td>Directory within the FTP site where the file is located.</td>
</tr>
<tr>
<td>File Name</td>
<td>Name of the file you want to download.</td>
</tr>
<tr>
<td>Username</td>
<td>Your user name for the FTP site.</td>
</tr>
<tr>
<td>Password</td>
<td>Your password for the FTP site.</td>
</tr>
</tbody>
</table>

© 2011 Epicor Software Corporation. All rights reserved.
### Field | Description
--- | ---
**Load PDW** | Whether to automatically import data into the PDW Catalog. Enter **Y** to allow the system to automatically import the data into the PDW Catalog; otherwise enter **N**. If you enter **N**, the system places the data in the directory defined in the **Local Path For PDW FTP Files** control maintenance record. **Note:** If you are downloading multiple files, the system places the files in the directory defined in the **Local Path For PDW FTP Files** control maintenance record. The system cannot import multiple files into the PDW Catalog simultaneously.

**Unzip File** | Whether to automatically unzip zipped files. Enter **Y** to allow the system to automatically unzip zipped files; otherwise enter **N**. If you enter **N**, the system places the zipped file in the directory defined in the **Local Path For PDW FTP Files** control maintenance record. **Note:** If the zipped file contains multiple files, the system places the files in the directory defined in the **Local Path For PDW FTP Files** control maintenance record. The system cannot download multiple files into the PDW Catalog simultaneously.

**Remove Remote File** | Whether to automatically delete the file from the remote FTP server after a successful download. Enter **Y** to allow the system to automatically delete the file; otherwise enter **N** to leave the file on the remote FTP server.

**Import Date Stamp** | Date you want this data to be stamped as effective in the PDW Catalog. For example, if you are importing new pricing information on 12/01/06, but the data is not effective until the new year, enter **01/01/07** as the **Import Date Stamp** to mark the information as inapplicable until the correct date.

**Allow New Item Creation** | Whether to create a new item in the PDW Catalog if the system does not find an existing matching product. Enter **Y** to create a new item; otherwise enter **N** to discard the import data. **Note:** If you do not correctly enter a matching metadata item and enter **Y** in the **Allow New Item Creation** field, the system uses this imported data to create a new item in the PDW Catalog.

**Matching Catalog Item** | Metadata item in the PDW Catalog to which to map the layout key. If you are using an existing import map, the system populates this field with the metadata item in the PDW Catalog to which the layout key is mapped. **Note:** Use the **Filter** hot key to build a filter for mapping the data to the correct metadata item. Use a filter when you use a catalog number that might not be unique to only the vendor providing the data.

**Key To Import** | Unique number, such as a UPC number, Manufacturer Catalog or Part number, or an NAED number, to define the key to the file for the import map. The system populates this field with the layout key you assigned to the import map when you created the map. **Note:** This field is view-only.
4. Use one of the following hot keys to update the PDW Catalog and exit the screen:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin</td>
<td>Runs the utility immediately in the foreground.</td>
</tr>
<tr>
<td>Schedule</td>
<td>Displays the Phantom Scheduler screen so you can schedule the utility.</td>
</tr>
</tbody>
</table>
PDW Data Proofing Overview

Use the PDW Data Proofing Report to compare data imports in the Product Data Warehouse (PDW) Catalog.

When you update the PDW Catalog, you assign a date stamp to the data you are importing. The system uses this date stamp to distinguish imports. Use the date stamp to identify the imports you want to compare.

For example: You update product information in the PDW Catalog. You want to see if the prices for this product have changed since the last update. Use the PDW Data Proofing Report to compare the two imports.

Enter the following to run the comparison report:

- In the Load Date field, enter the date for the current update.
- In the Compare Against field, enter Last Update.
- In the Data Element field, enter Price.
- Enter a price variance for the two imports between -5% and 5%.

The system creates a report comparing the two imports' pricing information. Review the report to see if the pricing has varied more than 5% in the newest import.

You can also define additional criteria for selecting PDW records to include in the report using the PDW Proofing Report Item Select screen. Define this criteria through conditional statements and conjunctive sentences.

See Also:

Running the PDW Data Proofing Report
Defining Selection Criteria for the PDW Data Proofing Report
Product Data Warehouse Overview
Running the PDW Data Proofing Report

Use the PDW Data Proofing Report to compare imports into the Product Data Warehouse (PDW) Catalog.

When you run the PDW Data Proofing Report, enter the two dates for the imports to compare, as well as filtering criteria to reduce the report to showing only the information you want to see. The filtering criteria includes:

- Whether to include new products in the comparison.
- Whether to include only products that exist in the Eclipse Product File.
- Which data element to compare.

For price comparisons, define a percentage range so the report shows only data that falls outside of the range.

To run the PDW Data Proofing Report:

1. From the Tools > Product Data Warehouse (PDW) menu, select **PDW Data Proofing Report** to display the PDW Data Proofing Report screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the **Report ID** field, enter a unique name for the report and press **Enter** at the **New** prompt if the report is new. If the report is not new, enter the unique ID previously assigned to it.

3. In the **Description** field, enter a report description. For example, enter **Primary Vendor Price Check** for a report comparing pricing for your primary vendor.

4. In the **Load Date** field, enter the date stamp for the import you want to compare.

5. In the **Compare Against** field, press **F10** and select one of the following:
   - **Last Update** - Compare the current import against the last import.
   - **Enter Date** - Enters a date stamp for another import.

6. In the **Display New Products on Report (Y/N)** field, enter **Y** or **N** to indicate if you want products that are new to the PDW Catalog from the current import displayed on the report.

7. In the **Only match records that exist in the product file** field, enter **Y** or **N** to indicate whether to limit the report to comparing data for records that already exist in the primary product file.

8. In the **Sort By** field, press **F10** and select one of the following sorting methods:
   - **Product ID**
   - **Price Line**
   - **UPC**
   - **Description**

9. In the **Data Element** field, enter the data element you want to compare, such as **Price**.
• Use the Get Meta hot key to compare all fields from one Import Layout ID. Enter the Import Layout ID at the prompt.

• Use the Source hot key to define an Import Layout ID and the date it first applied to the selected data element.

Note: When generated, the report displays the indicated data elements even if they did not contain values prior to the current update.

10. In the -Var % and +Var % fields, for pricing data, enter a percentage range to display data that falls outside of that range.
    For example, enter 5 in both columns to set a range between -5% and +5%. Data within this range does not display, but pricing data that has changed beyond this range does display.

11. Set options, if needed, and generate the report.

12. Press Esc to save changes and exit the screen.

More Options for Running the PDW Data Proofing Report

The PDW Data Proofing Report screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection</td>
<td>Displays the PDW Proofing Report Item Select screen.</td>
</tr>
<tr>
<td>Copy</td>
<td>Use to copy the currently displayed report setup information to a new report ID.</td>
</tr>
<tr>
<td>PDW Meta Mnt</td>
<td>Displays the PDW MetaData Maintenance screen. Use this screen to edit and view metadata item information.</td>
</tr>
</tbody>
</table>
Defining Selection Criteria for the PDW Data Proofing Report

Use the PDW Proofing Report Item Select screen to define additional criteria for selecting records from the Product Data Warehouse (PDW) Catalog to include in the report.

To define additional selection criteria, use a combination of verbs, modifiers, conjunctions, dictionary item names, and operators to create a conditional statement. The system uses the statement to select a subset of records in the file to use in generating the report.

You can define only one conditional statement for each report. One statement, however, can contain multiple conditions. The system evaluates the statement in the order it is entered.

For example, using the screen shot below, the system would evaluate the criteria entered on the screen as the following statement: If Vendor Catalog Number equals 123456 and Vendor UPC equals 12345678901, then select this data element.

![Screen Shot of PDW Proofing Report Item Select](image)

Note: The PDW functionality has not been incorporated into Solar Eclipse as of this release. Use the character-based system to access the screen displayed above.

To define additional selection criteria for the PDW Data Proofing Report:

1. From the Tools > Product Data Warehouse (PDW), select PDW Data Proofing Report to display the PDW Data Proofing Report screen.
   
   Note: If prompted, log on to the character-based system.

2. Define the report for which to enter additional selection criteria.

3. Use the Select hot key to display the PDW Proofing Report Item Select screen.
   
   The system populates the Report ID field with the report ID and description from the PDW Data Proofing Report screen.

4. In the Data Element field, enter the data element for which you want to define additional selection criteria.

5. In the Op field, press F10 and select one of the following characters to define the relationship between the data element and Compare To entry.
   
   • = Equal To
• # Not Equal To
• < Less Than
• > Greater Than
• <= Less Than or Equal To
• >= Greater Than or Equal To

6. In the **Compare To** field, enter the text or number to which you want to compare the data element.

   • Use a left square bracket ([ ] ) before a string of characters to select any record whose dictionary value ends with the text string entered (such as [ING]).

   • Use a right square bracket ([ ] ) after a string of characters to select any records whose dictionary value begins with the text string entered (such as VEN]).

   • Use [ before a string of characters and ] after a string of characters to select any record whose dictionary value contains the text string anywhere in the value (such as [UPC]).

7. In the **Conj** field, enter **And** or **Or** to indicate the linking phrase between multi-conditional statements.

   The first entry in the **Conj** field is *** to indicate the beginning of a conditional statement.

8. Use the following hot keys, as needed:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>PDW View Maint</td>
<td>Displays the PDW MetaData Maintenance screen for the data element on which your cursor is positioned.</td>
</tr>
<tr>
<td>PDW Data Viewer</td>
<td>Displays the PDW Data Viewer screen. Use this screen to view each field and its data for an indicated product.</td>
</tr>
</tbody>
</table>

9. Press **Esc** to apply the conditional statement and return to the PDW Data Proofing Report screen.
PDW Merge Utility Overview

Use the PDW to PDW File Merge Utility to join two or more product records and their data elements into one record in the Product Data Warehouse (PDW) Catalog. You can use the Merge Utility when a product is imported twice but into separate PDW records. You can also run a purge to remove the duplicate file.

For example, if two records for the same widget are created due to an incorrect import, use the Merge Utility to combine these two records into one, combining any duplicate information and including all data elements.

The Merge Utility provides a search function, which you can use to find the product records to merge by searching product descriptions.

Use the PDW to PDW Product Merge Report to search for matching line items, view and edit merge details, and print merge reports.
Merging PDW Records

Use the PDW to PDW File Merge Utility to combine two records for the same product in the Product Data Warehouse (PDW). You can also run a purge to remove the duplicate file.

For example, if two records for the same widget are created due to an incorrect import, use the Merge Utility to combine these two records into one, combining any duplicate information and including all data elements.

Before you can do a merge, you must find the product records that need to be merged. Search for these records by indicating the date the records were loaded, any metadata items they share, or any parametric data they share.

To merge PDW records:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW to PDW File Merge Utility to display the PDW to PDW Merge Utility screen.
   Note: If prompted, log on to the character-based system.

2. In the Select Catalog By field, press F10 and select one of the following ways to select the products to merge:
   - Load Date/Data Source
   - Indexed Meta Item
   - Parametric Data

   Depending on your selection for the Select Catalog By field, the next two fields vary.

3. Complete the fields associated with the selected option:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load Date</td>
<td>Import date for the product you want to merge, such as 10/27/01. Import Layout ID for the product you want to merge, such as TS280.</td>
</tr>
<tr>
<td>Source</td>
<td></td>
</tr>
<tr>
<td>Indexed Meta Item</td>
<td>Metadata item on which to search, such as Manufacturer name. Value it should match, such as Syl.</td>
</tr>
<tr>
<td>Value</td>
<td></td>
</tr>
<tr>
<td>Parametric Data</td>
<td>Parametric metadata item on which to search, such as Manufacturer name. Value it should match, such as Syl.</td>
</tr>
<tr>
<td>Value</td>
<td></td>
</tr>
</tbody>
</table>

   Use the Multi hot key, as needed, to enter multiple sources or values to use for selecting metadata items.

4. In the Match On field, enter a metadata item for the product against which you want to verify the other product.

   For example, if the UPC numbers in the two product records identify them as the same product, enter UPC in the Match On field.

   Use the Filter 1 hot key to define a filter for the Match On metadata item, if necessary.
5. In the **Match To** field, enter the other product's metadata item that should match up with the **Match On** field's entry.

For example, if you entered **UPC** in the **Match On** field and the matching metadata item in the other product file is Vendor **UPC**, enter **Vendor UPC** in the **Match To** field.

Use the **Filter 2** hot key to define a filter for the **Match To** metadata item, if necessary.

6. In the **NonMatching Indexes** field, press **F10** and select either:
   - **Include** - Displays metadata items that do not match between the two product records.
   - **Exclude** - Displays only metadata items that match between the two product records.

7. In the **Sort By** field, press **F10** and select how to sort the products on the Merge Utility screen:
   - **Description**
   - **Unique Key**
   - **PDW ID**

Once you have entered data in these fields, the utility runs and displays the defined data.

8. Verify the data in the following columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
</table>
| **U**        | The system displays one of the following:  
|              | • **M** - The system found a single match. The system will merge these records when you use the **Update** hot key.  
|              | • * - The system found 1-20 matches. If you change the * to **M**, the system will perform the merge with the first product listed when you use the **Update** hot key.  
|              | • ! - The system found more than 20 matches. You cannot change this character to **M**. |
| **Unique Key** | The value for the metadata item entered in the **Match On** field. For example, if you entered **UPC** in the **Match On** field, the UPC number displays in this field. |
| **PDW ID1**  | The PDW ID for the first PDW product record. |
| **PDW Description 1** | The description of the first PDW product record. |
| **PDW ID2**  | The PDW ID for the second PDW product record. |
| **PDW Description 2** | The description of the second PDW product record. |

9. In the **U** column, enter **M** next to each row of PDW product records that you want to merge into one record.

Use the **Clear** hot key to clear all values in the **U** column.

10. Use the **Update** hot key to perform the merges.

11. Press **Esc** and enter **Y** at the prompt to save completed merge updates and to exit the screen.

   **Note:** Before exiting the screen, make sure that you have completed all merge activity. When you exit the PDW to PDW Merge Utility screen, you will lose any incomplete merge updates.
More Options for Merging PDW Records

The PDW to PDW Merge Utility screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID1</td>
<td>Displays the PDW Data Viewer for the first PDW product record.</td>
</tr>
<tr>
<td>ID2</td>
<td>Displays the PDW Data Viewer for the second PDW product record.</td>
</tr>
<tr>
<td>Search</td>
<td>Displays the PDW Catalog Search screen, which you can use to further search for matching records if the system does not find matches on the initial search.</td>
</tr>
<tr>
<td>Print</td>
<td>Displays the Hold Entry Pre-View screen, where you can view and print the PDW to PDW Product File Merge Report.</td>
</tr>
</tbody>
</table>
Searching for Matching PDW Product Records

Use the PDW Catalog Search screen to search the Product Data Warehouse (PDW) Catalog for product descriptions that match other product descriptions. The system displays this screen when you are running a merge and it does not find a match for the metadata item. To manually display the screen, use the Search hot key.

Search the PDW Catalog for matching product records by entering keywords of three characters or longer. The system displays all matching PDW product records containing the keywords. If only one match exists for the product record, the system enters that match on this screen.

To search for matching PDW product records:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW to PDW File Merge Utility to display the PDW to PDW Merge Utility screen.
   
   **Note:** If prompted, log on to the character-based system.

2. If the system does not automatically display the PDW Catalog Merge Search screen when you run the merge, use the Search hot key to display it.

   The system enters the first PDW product record data in the following fields:

<table>
<thead>
<tr>
<th>PDW Data Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PDW ID</td>
<td>The PDW product ID.</td>
</tr>
<tr>
<td>Unique Key</td>
<td>The PDW metadata item identifier.</td>
</tr>
<tr>
<td>Description</td>
<td>The first line of the PDW product's description.</td>
</tr>
</tbody>
</table>

3. In the Search Keywords field, enter the keywords you want the system to use in the search that are also part of the PDW product description.

4. Use the Search hot key to search the PDW Catalog.

   - If there are several matching descriptions, the system displays a list from which you can select the product record to merge. Once you select a product record, the system displays its information in the second PDW Data column.
   
   - If the system finds only one match, it displays the product and its information in the second PDW Data column.

5. Use the Accept hot key to accept the match for the merge and return to the PDW to PDW Merge Utility screen.
Viewing the PDW to PDW Product File Merge Report

When you run the PDW to PDW File Merge Utility, the system generates a report and places it in your Hold file. Use the report to view the results of the merge.

To view the PDW to PDW Product File Merge Report:
1. Run the PDW to PDW File Merge Utility.
   **Note:** If prompted, log on to the character-based system.
2. Use the **Print** hot key to display the PDW to PDW Product File Merge Report on the Hold Pre-View screen.
3. Review the report's information in the following fields:
   
<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>U</td>
<td>Indicates whether the product records will be merged or not:</td>
</tr>
<tr>
<td></td>
<td>• M - Merging.</td>
</tr>
<tr>
<td></td>
<td>• Blank - Not merging.</td>
</tr>
<tr>
<td>Unique Key</td>
<td>The value for the metadata item entered in the <strong>Match On</strong> field. For example, if you entered <strong>UPC</strong> in the <strong>Match On</strong> field, the actual UPC number displays in this field.</td>
</tr>
<tr>
<td>PDW ID1</td>
<td>The PDW ID for the first PDW product record.</td>
</tr>
<tr>
<td>PDW Description 1</td>
<td>The description of the first PDW product record.</td>
</tr>
<tr>
<td>PDW ID2</td>
<td>The PDW ID for the second PDW product record.</td>
</tr>
<tr>
<td>PDW Description 2</td>
<td>The description of the second PDW product record.</td>
</tr>
</tbody>
</table>

   **Note:** Use the **Right** and **Left Arrow** keys to scroll across the screen.
4. Press **Esc** to exit the screen.

More Options for Viewing the Merge Report

The following are some common options you might use when viewing the merge report:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Displays the Set-View Parameters Maintenance screen. Indicate the starting and ending columns and rows you want to print on this report.</td>
</tr>
<tr>
<td>Search</td>
<td>Displays a <strong>Search String</strong> prompt. Enter a string of keywords for which to search.</td>
</tr>
<tr>
<td>Page Skip</td>
<td>Displays a <strong>Page to View</strong> prompt. Enter the page number for the page you want to view.</td>
</tr>
<tr>
<td>Print</td>
<td>Displays the Print Options screen, which you can use to print the report.</td>
</tr>
<tr>
<td>View Detail</td>
<td>Allows you to view the detailed descriptions for the line item.</td>
</tr>
<tr>
<td>Edit Detail</td>
<td>If authorized, allows you to edit the descriptions for the line item.</td>
</tr>
</tbody>
</table>
PDW/Eclipse Product File Sync Utility Overview

Before you can export product data from the Product Data Warehouse (PDW) Catalog to the Eclipse Product File, you must sync PDW and Eclipse product records. Syncing connects PDW records to matching Eclipse records by storing the matching PDW ID in the Eclipse product record.

You can choose to run a normal sync or a quick sync.

- **Normal sync** - Displays a search screen each time it encounters a product that does not find a match. Use this displayed screen to search for a product match.

- **Quick sync** - Displays the products for which it cannot find matches, but it does not prompt you to manually search for matching records.

Use the PDW Product File Sync Report to search for matching line items, view and edit sync details, and print sync reports.

You can also unsync PDW and product records using the Unsync Utility. This function is most useful when you sync two records incorrectly. You can unsync the records and re-sync them to their correct matches.
Syncing PDW and Eclipse Product Files

Use the PDW/Eclipse Product File Sync Utility to connect records in the Product Data Warehouse (PDW) catalog with records in the Eclipse Product file. You can run the utility for a single price line or buy line, or for multiple price lines and buy lines.

- Run a normal sync to display a search screen for all products that do not find matches. Use this displayed screen to search for a product match.
- Run a quick sync to match products between the PDW and Eclipse product file without displaying products for which the system cannot find matches.

   **Note:** When passing data from the PDW/Eclipse Product File Sync Utility screen to an attached user-defined screen, the system will only pass IDs equal to ACTIVE. Contact Eclipse support personnel for more information on user-defined screens.

To sync PDW and Eclipse product files:

1. From the **Tools > Product Data Warehouse (PDW) > PDW/Eclipse Product File Sync Utilities** menu, select **PDW/Eclipse Product File Sync Utility** to display the PDW/Eclipse Product File Sync Utility screen.

   **Note:** If prompted, log on to the character-based system.

2. In the **Price Line** field, do one of the following to run the Sync utility for one or multiple price lines or buy lines.
   - For a single price line, enter the price line for which to run the Sync utility.
   - For multiple price lines, use the **Multi** hot key to select price lines for which to run the Sync utility.
   - For a single buy line, change the field name from **Price Line** to **Buy Line** by using the **Left Arrow** key to place the cursor on **Price Line** and then typing **Buy Line**. In the field, enter the buy line for which to run the Sync utility.
   - For multiple buy lines, change the field name from **Price Line** to **Buy Line** by using the **Left Arrow** key to place the cursor on **Price Line** and then typing **Buy Line**. In the field, use the **Multi** hot key to select buy lines for which to run the Sync utility.

   **Note:** If you leave this field blank, the system runs the program for all price lines or buy lines, as indicated. Running the sync for all lines can slow down your system. We recommend that you always enter one or multiple price lines or buy lines in this field.

3. In the **Quick Sync** field, indicate whether to run a quick sync:
   - **Y** - Runs a quick sync, which does not display the search screen for products without matches.
   - **N** - Runs a normal sync, which displays the search screen whenever it encounters a product for which it cannot find a match.

4. In the **Load Meta Data to Eclipse** field, enter **Y** or **N** to indicate if you want the PDW unique key to be written to the product file for the products.
If you enter N, the products are still synced, but the unique keys are not written to the product files.

5. In the **Sort By** field, press **F10** and select how to sort the products displayed on the sync utility screen:
   - **Description**
   - Catalog Number
   - UPC
   - Part Number

6. In the **Matching Indexes** field, press **F10** and select one of the following processing and listing selections:
   - **Include** - Select and list all Eclipse products, whether or not they are synced to a PDW product.
   - **Exclude** - Select and list only Eclipse products that are *not* synced to PDW products.
   - **Only** - Select and list only Eclipse products that are synced to PDW products.

7. In the **Eclipse Dict** field, enter the dictionary item to use as the primary matching criteria.
   For example, enter **UPC#** as the primary matching criteria between PDW products and Eclipse products.

8. In the **PDW Key** field, enter the PDW metadata item to match the dictionary items against.

9. Verify the syncing information in the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ecl Dict</td>
<td>The value for the dictionary item that you indicated in the <strong>Eclipse Dict</strong> field.</td>
</tr>
<tr>
<td>ID</td>
<td>The Eclipse internal product ID.</td>
</tr>
<tr>
<td>Eclipse Description</td>
<td>The Eclipse product description.</td>
</tr>
<tr>
<td>PDW Description</td>
<td>The PDW product description.</td>
</tr>
<tr>
<td>Status</td>
<td>The sync status of the product:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Sync</strong> - Indicates the product has previously been synced to the PDW record.</td>
</tr>
<tr>
<td></td>
<td>- <strong>New</strong> - Indicates the product matches a PDW record and can be synced to it.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Blank</strong> - If you leave this field blank, the product is not synced.</td>
</tr>
</tbody>
</table>

**Note:** A **Checking** prompt displays at the top of the screen after you run the sync utility. This prompt indicates how many items the system checked in the price line and the percentage of the items that matched.

10. Use the **Sync** hot key to sync all items with the status of **New**.

11. Press **F12** and enter **Y** at the **Do You Wish to Abort** prompt to exit the screen.

   **Note:** To exit the PDW/Eclipse Product File Sync Utility screen at any time, press **F12** and answer **Y** at the prompt. The **Esc** key does not function on this screen.
More Options for Syncing PDW and Eclipse Product Files

The PDW/Eclipse Product File Sync Utility screen also offers the following options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sync</td>
<td>Syncs the matched products from the Product Data Warehouse (PDW) catalog and the Eclipse product file.</td>
</tr>
<tr>
<td>Schedule</td>
<td>Displays the Options screen, where you can schedule the utility to run at a later time.</td>
</tr>
<tr>
<td>Search</td>
<td>Displays the PDW Catalog Search screen., where you can search the PDW catalog for product records that match Eclipse product records.</td>
</tr>
<tr>
<td>PDW Data Viewer</td>
<td>Displays the PDW Data Viewer screen, where you can view the PDW data for the product on which the cursor is positioned.</td>
</tr>
<tr>
<td>Product Maint</td>
<td>Displays the Product Maintenance screen for the product on which the cursor is positioned. If authorized, you can edit the information for the product on this screen.</td>
</tr>
<tr>
<td>Filter</td>
<td>Displays the Filter Builder screen, where you can build a filter for searching the product database.</td>
</tr>
</tbody>
</table>
Searching for Matching PDW and Eclipse Products

The system displays the PDW Catalog Search screen when you are running a normal sync and the system comes upon a product without a match in the PDW Catalog. If you run a quick sync, use the Search hot key to display this screen.

Use the PDW Catalog Search screen to search the Product Data Warehouse (PDW) Catalog for product descriptions that match Eclipse product descriptions. Search the PDW Catalog for matching products by entering keywords of three characters or longer. The system displays all matching PDW products containing the keywords. If only one match exists for the Eclipse product, the system displays that match on this screen.

To search for matching Eclipse and PDW products:

1. Run the PDW/Eclipse Product File Sync Utility.
   Note: If prompted, log on to the character-based system.

2. If the system does not automatically display the PDW Catalog Search screen when you run the sync, use the Search hot key to display it.

   The system populates the following fields with the Eclipse product data:

<table>
<thead>
<tr>
<th>Eclipse Data Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product ID</td>
<td>The Eclipse internal product ID.</td>
</tr>
<tr>
<td>UPC</td>
<td>The Eclipse product's UPC.</td>
</tr>
<tr>
<td>Price Line</td>
<td>The price line assigned to the Eclipse product.</td>
</tr>
<tr>
<td>Description</td>
<td>The first line of the Eclipse product's description.</td>
</tr>
</tbody>
</table>

3. In the Search Keywords field, enter the keywords you want the system to use in the search that are also part of the PDW product description.
   - If there are several matching descriptions, the system displays a list from which you can select the product to sync. Once you select a product, the system displays its information in the PDW Data column.
   - If the system finds only one match, it displays the PDW data in the following PDW Data fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PDW ID</td>
<td>The PDW product ID.</td>
</tr>
<tr>
<td>Unique Key</td>
<td>The PDW metadata item identifier.</td>
</tr>
<tr>
<td>Description</td>
<td>The first line of the PDW product's description.</td>
</tr>
</tbody>
</table>

4. Use the Accept hot key to accept the match for the sync and return to the PDW/Eclipse Product File Sync Utility screen.
More Options

The PDW Catalog Search screen also offers the following options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Skip</td>
<td>Skips to the next product that does not have a match without having to match the currently displayed product.</td>
</tr>
<tr>
<td>Data Viewer</td>
<td>Displays the PDW Data Viewer screen, where you can view PDW product data.</td>
</tr>
<tr>
<td>Product Maint</td>
<td>Displays the Product Maintenance screen, where you can view Eclipse product data.</td>
</tr>
<tr>
<td>PM Upload</td>
<td>Use to create a PDW product record from the displayed Eclipse product record's data. At the prompt enter Y to create the product record in the PDW Catalog.</td>
</tr>
</tbody>
</table>
Viewing the PDW Product File Sync Report

When you run the PDW/Eclipse Product File Sync Utility, the system generates a report and places it in your Hold file. Use the report to view and print the results of the sync.

To view the PDW Product File Sync Report:

1. Run the PDW/Eclipse Product File Sync Utility.
   
   Note: If prompted, log on to the character-based system.

2. Use the Report hot key to display the Hold Entry Pre-View screen for the PDW Product File Sync Report.

3. Review the report's information in the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eclipse Dictionary Value</td>
<td>The value for the dictionary item.</td>
</tr>
<tr>
<td>ID</td>
<td>The Eclipse internal product ID.</td>
</tr>
<tr>
<td>Eclipse Description</td>
<td>The Eclipse product description.</td>
</tr>
<tr>
<td>PDW Description</td>
<td>The PDW product description.</td>
</tr>
<tr>
<td>Status</td>
<td>The sync status of the product:</td>
</tr>
<tr>
<td>Sync</td>
<td>Indicates the product has previously been synced to the PDW record.</td>
</tr>
<tr>
<td>New</td>
<td>Indicates the product matches a PDW record and can be synced to it.</td>
</tr>
<tr>
<td>Blank</td>
<td>If you leave this field blank, the product is not synced.</td>
</tr>
</tbody>
</table>

Note: Use the Right and Left Arrow keys to scroll across the screen.

4. Press Esc to exit the screen.

More Options for Viewing the Sync Report

The following are some common options you might use when viewing the Sync Report.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Displays the Set-View Parameters Maintenance screen. Indicate the starting and ending columns and rows you want to view on this report.</td>
</tr>
<tr>
<td>Search</td>
<td>Displays a Search String prompt. Enter a string of keywords for which to search.</td>
</tr>
<tr>
<td>Page Skip</td>
<td>Displays a Page to View prompt. Enter the page number for the page you want to view.</td>
</tr>
<tr>
<td>Print</td>
<td>Displays the Print Options screen, which you can use to print the report.</td>
</tr>
<tr>
<td>View Detail</td>
<td>Allows you to view the detailed descriptions for the line item.</td>
</tr>
<tr>
<td>Edit Detail</td>
<td>If authorized, allows you to edit the descriptions for the line item.</td>
</tr>
</tbody>
</table>
Unsyncing Products from PDW

If you incorrectly sync a product price line to the Product Data Warehouse (PDW) Catalog, use the Unsync utility to undo that sync. You can then re-sync the items in the price line to different PDW products.

When you unsync a price line, the system reassigns the internal IDs to new synced products.

To unsync a price line from the PDW:

1. From the Tools > Product Data Warehouse (PDW) > PDW/Eclipse Product File Sync Utilities menu, select PDW/Eclipse Product File Batch Un-Sync Utility to display the PDW Unsync screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Price Line field, enter the price line you want to unsync from the PDW Catalog.

3. Use either the Begin hot key to start the unsyncing or the Schedule hot key to schedule the unsync to occur on an indicated date and time, and to exit the screen.
   
   The system removes the PDW ID from each Eclipse product record in the designated price line.
PDW Export Overview

After you sync all of your Product Data Warehouse (PDW) products to Eclipse products, you can export data elements from the PDW Catalog to the Eclipse Product File in order to create Eclipse product records out of PDW product records.

The first step in exporting data from the PDW Catalog into the Eclipse Product File is to map the PDW data and pricing elements to the dictionary items. Use PDW Data Export Maintenance and PDW Price Export Maintenance to map the data and pricing elements.

After you have mapped the metadata items to the Eclipse Product File, use Eclipse Product File Batch Update to export the data into the Eclipse Product File.

You can also use the PDW Mass Product Export Utility to export products without Eclipse product files from the PDW Catalog into the Eclipse Product File.

After exporting, you have completed the main PDW function of merging your product records with the Eclipse Product File. From here forward, you will only need to maintain your product file using PDW.
Mapping PDW Data Elements to Eclipse Dictionary Items

You need to define export maps before you export data into the Eclipse Product file to ensure that all values for your metadata items follow the correct path to a dictionary item. Use PDW Data Export Maintenance to map Product Data Warehouse (PDW) metadata items to dictionary items.

To map metadata items match them to the correct dictionary item. For example, you would match the metadata item **UPC#** to the dictionary item **UPC**. For metadata items whose mapping is not as intuitive, use the PDW Data Viewer to view actual metadata item values. These values can help you determine which dictionary item the metadata item most matches.

The system provides a default map to help you get started in the export mapping process. On the default map, the system suggests the dictionary items most often mapped to. You must enter the metadata items to map to the dictionary items. You can also edit any dictionary items entered on the default map.

Like Import Map Maintenance, Export Maintenance also allows you to create translate and convert statements and filter the export. You can also assign priority to multiple metadata items which are mapped to the same dictionary item. This priority tells the system to use the item with highest priority when exporting.

Use Export Maintenance to run a sample export in order to ensure that you have mapped the metadata items correctly before running a true export.

**To create the default export map:**

1. From the **Tools > Product Data Warehouse (PDW) > PDW Export Maintenance** menu, select **PDW Data Export Maintenance** to display the PDW Export Maintenance screen.
   - **Note:** If prompted, log on to the character-based system.

2. In the **Export Map** field, press **F10** and select **Default** from the displayed list.
   - The system populates the **Description** field with **Default Map** and the **Eclipse Dictionary** column with all suggested dictionary items to map to metadata items.

3. In the **Eclipse Dictionary** column, you can do the following:
   - To delete a dictionary item, select the item and press **Alt-Delete**.
   - To add a dictionary item, position the cursor on a blank line, press **F10**, and select a dictionary item from the list. If necessary, from the displayed list you can press **F10** again to display a secondary list of archived dictionary items.
   - **Note:** Pressing **F10** does not display i-descriptors.

4. In the **Br/Tr/All** field, if the dictionary item is branch or territory specific, enter that branch or territory.
   - The system enters *********** if the dictionary item is not branch or territory specific.

5. In the **U** column, enter either:
   - **N** (nonstock or new) - Indicates the item is to be updated when new items are created in the Primary Product File through Nonstock Entry or PDW Mass Product Imports.
   - **B** (batch or both) - Indicates the item is to be updated when the Product File Batch Update program is run and when new items are created.
6. In the Pr column, if you are assigning more than one metadata item to a dictionary item, enter a priority number for the metadata items to indicate which item to export when both items exist in the PDW Product file. High numbers have higher priority.

7. In the PDW Meta Item column, enter the metadata item to map to the matching dictionary item.

8. Repeat steps 3-7, as needed, to add additional dictionary items.

9. Press Esc to save changes and exit the screen.


More Options for Creating the Default Export Map

The PDW Export Maintenance screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Use to view the mapping between metadata items and dictionary items by branch or territory.</td>
</tr>
<tr>
<td>Props</td>
<td>If highlighted in red for the selected dictionary item, use to enter settings for the dictionary item's properties, such as multi-valued or branch specific properties. Under the Settings column, enter the line or branch to use.</td>
</tr>
<tr>
<td>Translate</td>
<td>Displays the PDW Translation Table for the selected metadata item. Use this table to modify incoming or outgoing data elements in the PDW to match required formats.</td>
</tr>
<tr>
<td>Convert</td>
<td>Displays the PDW Conversion Table for the selected metadata item. Use this table to change the values of incoming or outgoing data elements in the PDW.</td>
</tr>
<tr>
<td>Dict</td>
<td>Displays the Dictionary Maintenance screen for the selected dictionary item. View the dictionary item's properties on this screen.</td>
</tr>
<tr>
<td>Meta</td>
<td>Displays the PDW Metadata Maintenance screen for the selected metadata item. View the metadata item's properties on this screen.</td>
</tr>
<tr>
<td>Sample Item</td>
<td>Use to view the actual data items that will be mapped according to the defined map.</td>
</tr>
<tr>
<td>Copy</td>
<td>Use to copy the current map to a new map. At the New Export Map ID prompt, enter an ID for the new map.</td>
</tr>
<tr>
<td>Delete</td>
<td>Use to delete the currently displayed export map. The system prompts you to confirm the deletion.</td>
</tr>
</tbody>
</table>
Creating Override Maps for PDW Product Exports

In Export Map Maintenance, besides the default map, you can also create override maps. These maps instruct the system to override the mapping on the default map if certain defined conditions exist.

For example, you map the dictionary item Ven Cat# on the default map to the Product Data Warehouse (PDW) metadata item Cat#. You want all Cat# metadata items with the value of 12345 to use a different export map. Create an override map, which instructs the system to use its mapping instead of the default mapping when it comes upon the catalog number of 12345 during export.

You create override maps by identifying a metadata item and its unique value. These tell the system to use a different export map. The system uses this override map every time it comes upon the metadata item with the unique value.

**Note:** You should create override maps only when advised by Eclipse support to do so.

To create an Override map:

1. From the Tools > Product Data Warehouse (PDW) > PDW Export Maintenance menu, select PDW Data Export Maintenance to display the PDW Export Maintenance screen.
   **Note:** If prompted, log on to the character-based system.

2. In the Export Map field, enter a new export map ID and press Enter at the New prompt.

3. In the Description field, enter a description for the map, such as Cat Override.

4. In the Trigger Meta field, enter the metadata item that the system needs to recognize as a flag to use this map instead of the default map if it contains the value defined in the next field.

5. In the Value field, enter the metadata item's value that triggers the system to use this map.

6. In the Eclipse Dictionary field, enter the dictionary items to which you want to map the metadata items.
   **Note:** You can press F10 to access a list of dictionary items from which to select, but this list only displays A- and D-Type Descriptors. Any dictionary item that is an I-Type Descriptor will not display on the list.

7. Finish creating the map as you would the default map.
   **Note:** Any data element that is not mapped in the override map uses the default map during export.
Mapping Multiple PDW Metadata Items to One Eclipse Dictionary Item

In Export Map Maintenance, in order to map multiple metadata items to one dictionary item, you must assign priorities to the metadata items so that the system knows which item to export when both exist in the same Product Data Warehouse (PDW) product record. Enter each metadata item on a separate line in order to assign separate priorities.

For example: If the TMS DiscClass, TMS Mfg. Name, and TMS Lynx ID metadata items were mapped to the BUY.LINE dictionary item, you would assign these metadata items priority numbers. If you assigned TMS DiscClass a priority of 99, TMS Mfg. Name a priority of 98, and TMS Lynx ID a priority of 97, then, where all three metadata items existed in a PDW product file, the system would write the TMS DiscClass with the priority of 99 to BUY.LINE since it has the highest priority number. See below.

Note: The PDW functionality has not been incorporated into Solar Eclipse as of this release. Use the character-based system to access the screen displayed above.

To map multiple metadata items to one dictionary item:

1. From the Tools > Product Data Warehouse (PDW) > PDW Export Maintenance menu, select PDW Data Export Maintenance to display the PDW Export Maintenance screen.

   Note: If prompted, log on to the character-based system.

2. In the Export Map field, enter the ID for the map you want to edit.

3. In the Eclipse Dictionary column, select or enter the dictionary item to which you want to map the metadata items.

4. In the PDW MetaData Item column, enter one of the metadata items that you want to map to the dictionary item.

5. Again in the Eclipse Dictionary column, enter the same dictionary item to which you are mapping the multiple metadata items.

6. In the PDW MetaData Item column, enter another metadata item that you want to map to the dictionary item.

7. Repeat this process until you have mapped all of the necessary metadata items to the one dictionary item.
8. In the **Pr** column, assign a priority to each metadata item.

   The higher numbers have higher priority, and the system exports the metadata item with the highest priority when several of the mapped metadata items exist in the same PDW product record.

9. After you have mapped all necessary data elements to dictionary items, press **Esc** to save changes and exit the screen.

Mapping PDW Metadata Items to Multi-Valued or Multi-Branched Dictionary Items

When you define dictionary items, which are user-defined fields, you may need to create multiple values for one dictionary item. You may also need to create one dictionary item for many branches or territories. For such dictionary items, indicate to what value or branch/territory you are mapping a Metadata item.

For dictionary items with multiple values, indicate the value on the Export Maintenance screen. Dictionary items with multiple values are named separately in Dictionary Maintenance. When you enter the dictionary item to which to map the metadata item, you also enter the value.

For dictionary items with multiple branches or territories, indicate the branch or territory on the PDW Export Maintenance screen.

By mapping to individual properties in dictionary items, you can ensure that only the intended values or areas are updated.

For example: If you want to update pricing for a dictionary item, but that item exists in three branches and you only want to update the first branch, you would map the metadata item to the first branch of the dictionary item.

To map a metadata item to a branch or territory within a dictionary item:

1. From the 'Tools > Product Data Warehouse (PDW) > PDW Export Maintenance' menu, select 'PDW Data Export Maintenance' to display the PDW Export Maintenance screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the Export Map field, press F10 and select the export map containing the metadata that you want to map.

3. In the Eclipse Dictionary field, select the dictionary item to which you are mapping the metadata item.

   Make sure that the metadata item you want to map to this dictionary item is in the matching PDW Meta Item field.

4. Use the Props hot key to display the PDW MetaData Properties screen.

   The system populates the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eclipse Dictionary</td>
<td>Dictionary item.</td>
</tr>
<tr>
<td>Property</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Multi Value Pos – Indicates the dictionary item is multi-valued.</td>
</tr>
<tr>
<td></td>
<td>• Enter Br/Tr/All – Indicates that the dictionary item is branch-specific.</td>
</tr>
</tbody>
</table>

5. In the Setting field, do one of the following:

   • For Multi Value Pos, view the value to which this item is mapped.
   • For Enter Br/Tr/All, enter the branch, territory, or All to which you want to map this item.

   **Note:** Use the Delete Settings hot key to delete any incorrect mapping.
6. Press **Esc** to save changes and return to the PDW Export Maintenance screen.

7. Run the Eclipse Product File Batch Update.
**Viewing Sample Data for PDW Exports**

Use the Sample Item hot key on the PDW Export Data Maintenance screen to view the actual data that will be mapped to the Eclipse Product File.

The PDW Data Sample screen displays:

- The dictionary item which receives the information.
- The branch or territory to which the information is mapped.
- The actual value exported into the Eclipse Product File.
- The export map used to export the data.

**To view sample data for exports:**

1. From the Tools > Product Data Warehouse (PDW) > PDW Export Maintenance menu, select PDW Data Export Maintenance to display the PDW Export Maintenance screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the Export Map field, enter the ID of the map for which you want to view sample data.
3. Use the Sample Data hot key to view a sample mapping.
4. At the This Will Update All Items. Continue? prompt enter Y to continue.
   
   **Note:** This updates the Export Map but not the actual data.

5. At the Enter UPC#/Keywords prompt, enter the PDW product record for which to run the sample update.

The system displays the PDW Data Sample screen with the following information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>The product description and product ID for which you are viewing the sample update.</td>
</tr>
<tr>
<td>Dictionary</td>
<td>The dictionary item to which the data is mapped.</td>
</tr>
<tr>
<td>Br/Terr</td>
<td>The branch or territory to which the data applies.</td>
</tr>
<tr>
<td></td>
<td>• All - Indicates that the data applies to all branches and territories.</td>
</tr>
<tr>
<td></td>
<td>• ******** - Indicates that the data is not branch or territory specific.</td>
</tr>
<tr>
<td>MV</td>
<td>If the dictionary item has multiple values mapped to it, the value being used for the export identified by its priority number.</td>
</tr>
<tr>
<td>Value</td>
<td>The actual data exported into the dictionary item.</td>
</tr>
<tr>
<td>Export Map</td>
<td>The export map used for the export update.</td>
</tr>
</tbody>
</table>

Press Esc to return to the PDW Export Maintenance screen.
More Options for Viewing Export Sample Data

The PDW Data Sample screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map</td>
<td>The PDW Export Maintenance screen for the export map being used.</td>
</tr>
<tr>
<td>Data Viewer</td>
<td>The PDW Data Viewer screen for the product.</td>
</tr>
<tr>
<td>Expand</td>
<td>The complete value if it is too long to fit in the Value column.</td>
</tr>
</tbody>
</table>
Mapping PDW Price Elements to Eclipse Pricing Basis Names

Use the PDW Price Export screen to:

- Map Product Data Warehouse (PDW) pricing elements to Basis Names defined in Pricing Maintenance.
- Define pricing formulas for the pricing values that are being exported into the Eclipse Product File.

**Note:** If you are not familiar with Eclipse's Pricing utility, see Pricing Maintenance.

Like the data Export Maintenance screen, you can have both default and override maps for pricing exports. The default pricing export map provides 20 basis names to which you can map PDW pricing elements. For each basis name, you can define calculation formulas to modify the pricing element value, as necessary. These calculation formulas work much like translate statements for data elements.

For example, you can double a list cost when you export it into your Eclipse Product File by entering a formula that tells the system to multiply the pricing element value by two.

Also like data export maps, you can assign priority to multiple price elements mapped to the same basis, and you can see a sample export before running the actual export.

You can edit the default map, as necessary.

**To create the default map for PDW pricing elements:**

1. From the 'Tools > Product Data Warehouse (PDW) > PDW Export Maintenance' menu, select 'PDW Price Export Maintenance' to display the PDW Price Export Maintenance screen.
   **Note:** If prompted, log on to the character-based system.

2. In the Line field, use the Edit Default hot key to display the default map.

3. In the Basis Names column, press F10 and select Basis 1 to define your first price export.
   **Note:** For the default map, you can use Basis 1-20 consecutively to define your pricing export map.

4. In the Calc Base column, enter one of the following calculation basis:
   - **Enter** - Manually assign a new default value to the basis name.
   - **Previous** - Assign the same cost or price for the new effective export date as was assigned to the previous effective export date.
   - **No Update** - Keep the cost or price as it is.
   - Another basis name associated with this price line in order to use its formula.

5. In the Formula column, enter a pricing formula, like the ones explained in the table below:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Specifies...</th>
</tr>
</thead>
<tbody>
<tr>
<td>+n</td>
<td>Basis plus the number that follows (for example, +1).</td>
</tr>
<tr>
<td>-n</td>
<td>Basis minus the number that follows (for example, -1).</td>
</tr>
<tr>
<td>Formula</td>
<td>Specifies...</td>
</tr>
<tr>
<td>---------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>*n</td>
<td>Basis multiplied by the number that follows (for example, *2). Use *1 to indicate that you want the value to remain as it is.</td>
</tr>
<tr>
<td>dn</td>
<td>Basis divided by the number that follows (for example, d2).</td>
</tr>
</tbody>
</table>

6. In the R column, enter the number of places to round the number.

7. In the Pr column, if you are assigning more than one price element to a basis, enter a priority number for the pricing elements so that the system knows which element to export when both elements exist in the PDW Catalog. Higher numbers have higher priority; however, the system considers a line with a blank priority as the highest priority.

8. In the Meta Item column, enter the metadata pricing element that you want to map to the basis.

   In the Zone/Sht column, the system enters ******** because pricing zones are not associated with the default map. You can enter pricing zones on override maps.

9. Press Esc to save changes and exit the screen.


**More Options for Creating the Default Pricing Export Map**

The PDW Price Export Maintenance screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample Item</td>
<td>Shows the actual data elements that will be mapped according to the defined map.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the current map to a new map. At the New Price Line prompt, enter the price line to use for the new map.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the currently displayed export map. The system prompts you to confirm the deletion.</td>
</tr>
</tbody>
</table>
Creating an Override Map for PDW Price Exports

In PDW Price Export Maintenance, you can create override maps in order to map Product Data Warehouse (PDW) pricing elements to existing price lines, price sheets, and discount classes.

Create price override maps by entering an actual price line and sheet from your pricing files on the PDW Price Export Maintenance screen. You can then map the PDW price elements to defined basis names within the price line and sheet.

On an override map, you can also define any pricing zones that may exist for the PDW pricing element.

To create an export price override map:

1. From the Tools > Product Data Warehouse (PDW) > PDW Export Maintenance menu, select PDW Price Export Maintenance to display the PDW Price Export Maintenance screen.
   Note: If prompted, log on to the character-based system.
2. In the Line field, enter the price line you want to use for the override map.
   The system displays a list of all price sheets and discount classes for the price line.
3. Select a price sheet to use for the override map.
   Note: Sheets with asterisks (*) next to them already have override maps defined for them. You can edit these maps.

   The system enters the Price Sheet and Discount Class in their fields. A tilde (~) represents the default price sheet or discount class for the price line.
4. In the Basis Names column, if the system did not populate it with all needed basis names for the current price sheet, press F10 and select a name to enter.
5. In the Pr column, enter a priority of 50 or higher for the system to use the override map instead of the default map.
6. In the Zone/Sht field, if the metadata item has multiple price sheets for multiple branches, enter the pricing zone for it.
   • The system enters ******** if the metadata element does not have pricing zones associated with it.
   • Use the Expand hot key to expand the entry in the Zone/Sht column if it does not fit in the allotted space.
7. Finish the map as you would the default map.
Exporting PDW Data to the Eclipse Product File

After you map your metadata items from the Product Data Warehouse (PDW) Catalog to the Eclipse Product file, use the Eclipse Product File Batch Update screen to export the data. This program takes the data from the most recent update of the PDW Catalog and updates the primary Product file.

On the Eclipse Product File Batch Update screen, indicate a price line and the type of update (pricing or non-pricing information).

When doing a batch price update, the **Allow Price Sheet Per Qty And UOM To Change On PDW Price Update** control maintenance record determines whether the system changes the price per unit of measure and price per unit of measure quantity on the product price sheet in the Product file to match the PDW.

- If this record is set to Y, the system changes the price per unit of measure and the price per unit of measure quantity on the Eclipse product price sheet to match the UOM data in the PDW. For any Eclipse products that the system updates, you will need to manually adjust the average cost unit of measure for the branch on the Branch Costs screen and any UOM-specific sell matrix cells.
- If this record is set to N, the pricing unit of measure on the Eclipse price sheet does not change when the corresponding PDW information changes.

Run a preview before actually updating to ensure that the export is correctly set up.

To export PDW data to the Eclipse Product file:

1. From the **Tools > Product Data Warehouse (PDW)** menu, select **Eclipse Product File Batch Update** to display the Eclipse Product File Batch Update screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the **Price Line** field, enter a price line that you want to update.
   
   - Use the **Multi** hot key to select multiple price lines for which to run the update.
   
   - If you leave this field blank, the system prompts whether you want to update all price lines. Enter Y to update all price lines or N to update only the items indicated in the item list.

3. In the **PDW Update Date** field, enter the PDW update date to use for updating the Eclipse Product file.
   
   If you leave this field blank, the system runs the most recent update.

4. In the **Update Type** field, press **F10** and select either:
   
   - **Price** - Updates all pricing records in the Eclipse Product file.
   
   - **Data** - Updates all non-pricing records in the Eclipse Product file.

5. In the **Print Update Report** field, enter Y or N to indicate whether you want the system to print an Update Report, which lists all items that changed with the update.

6. In the **Print Error Report** field, enter Y or N to indicate whether you want the system to print an Error Report, which lists all items that did not change with the update and the reasons why.

   **Note:** We recommend that you enter Y in the **Print Update Report** and **Print Error Report** fields in order to check the update for any errors.
7. Use the **Preview** hot key to generate both reports and view the dictionary items that will update for each product, along with the new values, without actually running the update.

   If you are running a Price update, then the PDW Price Update Scan screen displays when you use the **Preview** hot key. Use this screen to verify that the correct price sheets and discount classes are being used for price lines that you are updating.

8. Use the **Update** hot key to run the update and exit the screen.

**More Options for Exporting Data into the Eclipse Product File**

The Eclipse Product File Batch Update screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Price Sheet Scan</strong></td>
<td>Displays the PDW Price Update Scan screen.</td>
</tr>
<tr>
<td></td>
<td>This hot key is active only when the update type is <strong>Price</strong>.</td>
</tr>
<tr>
<td><strong>Item List</strong></td>
<td>Displays the PDW Batch Update Item List screen, which lists all products in the Eclipse Product file that will be updated.</td>
</tr>
</tbody>
</table>
Editing and Verifying PDW Product Updates

Use the PDW Batch Item Update screen to view the products that are being updated when you run a batch update. This verification is important to run in order to make sure that you are correctly updating the Eclipse Product File before actually updating it.

Edit the items on the PDW Batch Item Update screen if you need to add more items to the update or delete items from the update.

To verify which products are being updated:

1. From the Tools > Product Data Warehouse (PDW) menu, select Eclipse Product File Batch Update to display the Eclipse Product File Batch Update screen.
   
   Note: If prompted, log on to the character-based system.

2. Define the export data.

3. Use the Item List hot key to display the PDW Batch Update Item List screen.

4. Verify that the correct products are being updated in the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>The Eclipse product description.</td>
</tr>
<tr>
<td></td>
<td>• To add an item, press Alt-Insert and enter the Eclipse product description. Select the correct product from the list. The system enters the product ID in the ID field.</td>
</tr>
<tr>
<td></td>
<td>• To delete an item, select the item and press Alt-Delete.</td>
</tr>
<tr>
<td>ID</td>
<td>The Eclipse product ID.</td>
</tr>
</tbody>
</table>

5. Use the following hot keys, as needed:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Maint</td>
<td>Displays the Product Maintenance screen for the item on which the cursor is positioned.</td>
</tr>
<tr>
<td>PDW Data Viewer</td>
<td>Displays the PDW Data Viewer screen for the item on which the cursor is positioned.</td>
</tr>
<tr>
<td>Clear All</td>
<td>Clears all products from the screen so that they are not be updated.</td>
</tr>
</tbody>
</table>

6. Press Esc to return to the Eclipse Product File Batch Update screen.
Verifying Price Sheets for PDW Price Updates

Use the PDW Price Update Scan Screen to verify that the correct price sheets and discount classes are being used for price lines that you are updating. You want to verify the price sheets and discount classes to which a price line applies in order to make sure that the correct formula is being used in the update. From this screen, you can also view and edit the actual price sheet formulas being applied to the price line and the actual items being affected by the update.

You only need to access this screen when you are running pricing updates from the Eclipse Product File Batch Update screen.

To verify that correct price sheets are being used:

1. From the Tools > Product Data Warehouse (PDW) menu, select Eclipse Product File Batch Update to display the Eclipse Product File Batch Update screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Price Line field, enter the price line you want to update.

3. Use the Price Sheet Scan hot key to display the PDW Price Update Scan screen.

4. View the data in the following columns to verify the price sheets:

<table>
<thead>
<tr>
<th>Column</th>
<th>Displayed Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>The price line entered on the Eclipse Product File Batch Update screen. If an asterisk (*) is next to a price line, either the price sheet does not have an effective date or the price sheet has a calculation status of No Update. Verify that these price sheet formulas are correct. Use the Formulas hot key to display the PDW Price Export Maintenance screen and view the price sheet formulas.</td>
</tr>
<tr>
<td>Price Sheet</td>
<td>The price sheet being used to update the product pricing within the price line. If this column is blank, then the default price sheet is being used.</td>
</tr>
<tr>
<td>Disc Class</td>
<td>If discount classes are assigned to the price sheet and product, the discount class being used.</td>
</tr>
<tr>
<td>Item Ct</td>
<td>The number of products being updated using the respective price sheet and discount class, if applicable.</td>
</tr>
<tr>
<td>Last Eff</td>
<td>The most recent effective date for the respective price sheet. The system uses the effective date's formulas for the pricing update. Use the Eff Date hot key to select a different effective date or to assign a new effective date.</td>
</tr>
<tr>
<td>Load Eff</td>
<td>The most recent effective date for the respective price sheet. The system uses the effective date's formulas for the pricing update. Enter a new date to create a new price sheet effective date. The formulas from the price sheet's last effective date is copied to the new effective date.</td>
</tr>
</tbody>
</table>

5. In the Upd column, enter Y or N for each line item to indicate if you want the price class and sheet updated.

6. Press Esc to save changes and return to the Eclipse Product File Batch Update screen.
More Options for Verifying Price Sheets

The PDW Price Update Scan screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formulas</td>
<td>Displays the PDW Price Export Maintenance screen. Use this hot key to create an override map for the selected price line and price sheet.</td>
</tr>
<tr>
<td>Set All Last Dts</td>
<td>Copies the selected date in the Last Eff Dt column to all Last Eff Dt entries.</td>
</tr>
<tr>
<td>Set All Load Dts</td>
<td>Copies the selected date in the Load Eff Dt column to all Load Eff Dt entries.</td>
</tr>
<tr>
<td>Report</td>
<td>Prints a report listing all data displayed on the PDW Price Update Scan screen.</td>
</tr>
<tr>
<td>Items</td>
<td>Displays the PDW Price Update Scan Items screen. Use this screen to view the associated items being updated for the selected price sheet.</td>
</tr>
</tbody>
</table>
Verifying PDW Products Assigned to a Price Sheet

Use the PDW Price Update Scan Items screen to verify which product prices are being updated using the respective price sheet on the PDW Price Update Scan screen. You want to verify the products to which a price sheet applies in order to make sure that the correct formula is being used in the update for the product.

To verify that the correct price sheets are being applied to products:

1. From the Tools > Product Data Warehouse (PDW) menu, select Eclipse Product File Batch Update to display the Eclipse Product File Batch Update screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Price Line field, enter the price line you want to update.

3. Use the Price Sheet Scan hot key to display the PDW Price Update Scan screen.

4. Select the price sheet to view and use the View Items hot key to display the PDW Price Update Scan Items screen.

5. View the product information in the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Price Line</td>
<td>The price line to which the price sheet belongs.</td>
</tr>
<tr>
<td>Price Sheet</td>
<td>The price sheet being applied to the product.</td>
</tr>
<tr>
<td>Discount Class</td>
<td>The discount class being used, if applicable.</td>
</tr>
<tr>
<td>UPC</td>
<td>The product UPC number.</td>
</tr>
<tr>
<td>ID</td>
<td>The Eclipse product ID.</td>
</tr>
<tr>
<td>Eclipse Description</td>
<td>The Eclipse product description.</td>
</tr>
</tbody>
</table>

6. Use the screen hot keys to view the following:
   - **Product Maint** - View the Product Maintenance screen.
   - **PDW Data Viewer** - View the PDW Data Viewer screen.

7. Press Esc twice to return to the Eclipse Product File Batch Update screen.
Running the PDW Price Sheet Formulas Report

Use the PDW Price Sheet Formulas Report to view your pricing files and to ensure accuracy of product pricing. This report lists all Product Data Warehouse (PDW) products for an indicated price line and price sheet.

When you define pricing export maps, this report can assist you in matching PDW pricing data to the price lines, price sheets, discount classes, and formulas set up in the system. The report lists the metadata items mapped to the price sheets and their priority numbers.

To run the Price Sheet Formulas Report:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW Price Sheet Formulas Report to display the PDW Price Sheet Formulas Report screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Price Line field, enter the price line for the price sheet you want to view.
   
   If you leave this field blank, the system runs the report for all price lines in the indicated branch or territory, as well as for the Default price line.

3. In the Price Sheet field, enter the price sheet you want to view.
   
   If you leave this field blank, the system runs the report for all price sheets within the indicated price line and branch or territory, as well as for the Default price sheet.
   
   To enter a list of price sheets for which to run the report, use the Multi hot key. The system displays *Multi* in the Price Sheet field, indicating that the report includes multiple price sheets.

4. Set options, if needed, and generate the report.
Running Eclipse Product File Batch Update Reports for PDW

The Eclipse Product File Batch Update Reports display items that either change or are not affected by the PDW update.

**Update Report**

The Update Report lists all items that changed with the update and the following information:

- Eclipse product number and description.
- UPC number.
- Price line, price sheet, and discount class for product.
- Dictionary item that is updated.
- Old value for dictionary item and new value for dictionary item.
- Variance between old and new values.

Use the Preview hot key on the Eclipse Product File Batch Update screen to run this report. View the report from the Report Queue. Use the Sample icon below to view a sample of this report.

**Error Report**

The Error Report lists all items that did not change with the update and the reasons why in the following information:

- Eclipse product number and description.
- UPC number.
- Price line, price sheet, and discount class for product.
- Why product will not change.

Use the Preview hot key on the Eclipse Product File Batch Update screen to run this report. View the report from the Report Queue. Use the Sample icon below to view a sample of this report.
Defining Fields for the PDW Mass Product Export Screen

Each time you use the PDW Mass Product Export utility, use the PDW Mass Product Export Screen Layout Editor to identify fields from the Product Data Warehouse (PDW) Catalog whose metadata values you want to display on the PDW Mass Product Export screen. These fields assist you in selecting correct products to export on the PDW Mass Product Export screen.

For example: If you define a catalog number as a field for the PDW Mass Product Export screen, then you can identify the products you are exporting by the catalog number displayed on the PDW Mass Product Export screen.

The fields you define appear to the right of the first two fields for the index and UPC codes on the PDW Mass Product Export screen.

The PDW Mass Product Export screen provides 63 character spaces for the fields. The sum of the widths of the defined fields and the column rules between each field must be less than or equal to 63. If the total number of characters exceeds 63, then the data in the last field truncates.

Note: Each column rule takes up one character, and the system enters column rules between each field.

To define fields for the PDW Mass Product Export screen:

1. From the Tools > Product Data Warehouse (PDW) > PDW Mass Product Exports menu, select PDW Mass Product Export Screen Layout to display PDW Mass Export Screen Layout Editor screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Col field, identify the column you want each metadata value to occupy.

3. In the PDW Meta Item field next to the respective column number, enter the PDW Catalog item to display on the PDW Mass Product Export screen.

4. In the Width field, enter the number of characters to allocate to this column.

5. In the Align field, enter L or R to indicate how to align the text within the column.

6. In the Column Label field, enter the label for the designated column.

7. Press Esc to save the defined layout and exit the screen.

8. Access the PDW Mass Product Export screen to define and run the export.
Exporting Mass Product Data From the PDW

Use the PDW Mass Product Export Utility to export large amounts of product information for products that do not exist in the Eclipse Product file yet from the Product Data Warehouse (PDW) Catalog into the Eclipse Product file. This utility saves you from having to create individual product records for each item you want to add to the Eclipse Product file.

For example, if you are a distributor that did not sell Leviton products in the past but have now started to sell Leviton products, use the PDW Mass Product Export Utility to populate the Eclipse Product file with these products instead of manually creating each product record.

Before exporting product data you need to complete the following tasks:

- Define a layout for the mass product export on the PDW Mass Product Export Screen Layout Editor screen.
- Map the PDW metadata items to the dictionary items in Export M

To export mass product data from the PDW:

1. From the 'Tools > Product Data Warehouse (PDW) > PDW Mass Product Exports menu, select PDW Mass Product Export Utility to display the PDW Mass Product Export screen.
   
   Note: If prompted, log on to the character-based system.

2. In the PDW Source field, enter the PDW data source, such as Trade Service, from which you are gathering the data.
   
   If you leave this field blank, the system displays all products from all sources.

3. In the Search Keywords field, enter an indexed metadata item to select the products you want to export.
   
   For example, if you want the system to select all products with the indexed metadata item LEV in their descriptions, enter LEV in this field.
   
   Note: You must enter a search keyword or use the Filter hot key to narrow the selection of products. The search keyword must be an indexed metadata item.

4. View the product information in the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID#</td>
<td>The product's ID number.</td>
</tr>
<tr>
<td>UPC</td>
<td>The product's UPC number.</td>
</tr>
</tbody>
</table>

   The remaining fields are the ones defined on the PDW Mass Export Screen Layout Editor screen.

5. In the column to the left of the ID# column, enter one of the following to indicate where the product record should be created:
   - P - List the product as a stock item in the Primary index.
   - C - List the product as a nonstock item in the Catalog index.
   - Blank - Do not create a product record for the product.
**Note:** If an asterisk (*) displays in this column, the product already exists in the Eclipse Product file. For such cases, you cannot export the product into the Eclipse Product file. Update the product file instead using the Eclipse Product File Update Utility.

6. Use the **Begin Export** hot key to export the data from the PDW Catalog into the Eclipse Product file, and exit the screen.

**More Options for Using the PDW Mass Product Export Utility**

The PDW Mass Product Export screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Displays the Filter Builder screen, which you can use to define selection criteria.</td>
</tr>
<tr>
<td>Product Maint</td>
<td>Displays the Product Maintenance screen for items that already exist in the Eclipse Product File. These are marked by asterisks (*).</td>
</tr>
<tr>
<td>PDW Data Viewer</td>
<td>Displays the PDW Data Viewer for the selected product.</td>
</tr>
<tr>
<td>Set All</td>
<td>Copies the value in the first column (P, C, or blank) of the selected line to all other lines that do not have an asterisk in that column.</td>
</tr>
</tbody>
</table>
PDW File Extract Utility Overview

Use the PDW File Extract Utility to download information from either the Product Data Warehouse (PDW) Catalog or the Eclipse Product file into an ASCII formatted file. The extract utility downloads PDW Catalog metadata items, Eclipse Product file dictionary items, and customer-specific prices. Use this utility to create a catalog of products that you can send electronically to your customers.

To extract data from the PDW Catalog and Eclipse Product file into an ASCII formatted file, you must design the extract to determine the format in which the data downloads. You can also filter the selection criteria so only certain data downloads to the ASCII file.

**Note:** You cannot use Eclipse Mass Load to download data from the PDW Catalog because the scalable file design of the PDW Catalog does not work effectively with Mass Load.
Extracting PDW and Eclipse Product Data

Use the PDW File Extract Utility to download data from the Product Data Warehouse (PDW) Catalog and Eclipse Product File into an ASCII formatted file.

You must design the format of how the data downloads on the PDW File Extract Utility screen. After you design the format and instruct the system to begin the extract, the system compiles all of the data into the correct format and messages you when the data is ready for download.

To extract PDW and Eclipse product data:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW File Extract Utility to display the PDW File Extract Utility screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Design ID field, enter the name for your extract design.

3. In the Description field, enter a description for your extract design, such as Pricing Download if you are downloading pricing information.

4. To download customer-specific part numbers or pricing, complete the following fields:
   
   • In the Customer field, enter the name of the customer.
   
   • In the Use Cus PN's field, enter Y to download only the products flagged for that customer.

5. In the Print Col Heading field, enter Y or N to indicate whether you want the column headings to download.

6. In the Layout field, press F10 and select either a Delimited layout or Fixed layout for the file.
   
   • If you select Fixed for the file layout, then skip the next two fields.
   
   • If you select Delimited for the file layout, then fill in the following two fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delim Character</td>
<td>The character that separates fields of data.</td>
</tr>
<tr>
<td></td>
<td>Note: For a tab delimiter, type TAB.</td>
</tr>
<tr>
<td>Envelope Character</td>
<td>The character to use to surround fields of data.</td>
</tr>
<tr>
<td></td>
<td>If your data contains commas (,) and you selected a comma for your delimiting character, use quotation marks (&quot;) as the enveloping character.</td>
</tr>
</tbody>
</table>

Use the Pricing Date, Pricing Branch, Qty, and UoM fields for pricing downloads only.
7. In the following columns, enter the file source and download layout information that you want to appear in the respective columns labeled in the Col column for your ASCII formatted file:

<table>
<thead>
<tr>
<th>Field</th>
<th>Entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>The type of data to display in the respective column. Press <strong>F10</strong> and select one of the following:</td>
</tr>
<tr>
<td></td>
<td>• <strong>PRD</strong> - Product file dictionary item.</td>
</tr>
<tr>
<td></td>
<td>• <strong>PDW</strong> - PDW Catalog metadata item.</td>
</tr>
<tr>
<td></td>
<td>• <strong>PRC</strong> - Customer price.</td>
</tr>
<tr>
<td></td>
<td>• <strong>PQTY</strong> - Pricing quantity.</td>
</tr>
<tr>
<td></td>
<td>• <strong>PUOM</strong> - Pricing UOM.</td>
</tr>
<tr>
<td></td>
<td>• <strong>CPN</strong> - Customer Part Number.</td>
</tr>
<tr>
<td>Dict/Meta Item</td>
<td>The dictionary or metadata item to download.</td>
</tr>
<tr>
<td>J</td>
<td>• <strong>L</strong> - Left justify the data in the field.</td>
</tr>
<tr>
<td></td>
<td>• <strong>R</strong> - Right justify the data in the field.</td>
</tr>
<tr>
<td>Width</td>
<td>For <strong>Fixed</strong> layouts only, the number of characters to allocate to this field.</td>
</tr>
<tr>
<td>Column Heading</td>
<td>• If you entered <strong>Y</strong> in the <strong>Print Col Heading</strong> field, the heading to display in the respective column.</td>
</tr>
<tr>
<td></td>
<td>• If you entered <strong>N</strong> in the <strong>Print Col Heading</strong> field, leave this field blank.</td>
</tr>
<tr>
<td>Format</td>
<td>Formatting for quantities needing decimals, such as <strong>MR2</strong> (mask right 2 positions).</td>
</tr>
<tr>
<td></td>
<td>Eclipse provides most formatting when it is needed.</td>
</tr>
</tbody>
</table>

9. Use either the **Begin** or **Schedule** hot key to start or schedule the file build, and exit the screen. The phantom runs the file build and messages you when it is finished and ready for download.

**More Options for Extracting Data**

The PDW File Extract Utility screen also offers these options.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Data</td>
<td>Displays the PDW File Extract Selection screen. Use this screen to define selection criteria for the file build.</td>
</tr>
<tr>
<td>Column Data</td>
<td>If a dictionary item can be updated, use this hot key to enter properties for the dictionary item. A columned screen appears where you enter the property data.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the current extract design.</td>
</tr>
</tbody>
</table>
Designing an Extract for PDW and Eclipse Pricing

When you download pricing information from the Product Data Warehouse (PDW) Catalog or Eclipse Product File into an ASCII formatted file, you need to define four additional settings on the PDW File Extract Utility screen. Design the rest of the extract as you do for any extract design.

To design an extract for PDW and Eclipse pricing information:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW File Extract Utility to display the PDW File Extract Utility screen.
   
   Note: If prompted, log on to the character-based system.

2. Populate this screen's fields with the necessary data as you do for any extract design.

3. In the Pricing Date field, enter the pricing date on which to calculate the prices.

4. In the Pricing Branch field, enter the branch whose pricing you want to use.

5. In the Qty field, if you want to price all items based on a unit of measure (UOM), enter the quantity of individual items in that UOM. Define the UOM in the UoM field.

6. In the UoM field, if you want to price all items based on a UOM, enter that UOM. Enter the quantity of individual items that make up a UOM in the Qty field.

   For example: You want to price all items in units of boxes. Ten individual items fill one box. Enter 10 in the Qty field and enter bx for units of boxes in the UoM field. The system will price all items as one box, each holding 10 items.

7. Complete the design as you do any extract design.
Defining Selection Criteria for a PDW and Eclipse Extract

If you want to define filtered selection criteria for an extract file, use the PDW File Extract Selection screen. This screen functions much like the PDW Proofing Report Item Select and Filter Builder screens. You can enter comparative statements to narrow the system's selection of files for the extract.

For example, to extract all files with a product description containing LEV, create a filter similar to the one below:

![Filter Screen](image)

Based on these criteria, the system selects all items that contain Lev in the product description.

**Note:** The PDW functionality has not been incorporated into Solar Eclipse as of this release. Use the character-based system to access the screen displayed above.

**To define a selection filter for an extract file:**

1. From the **Tools > Product Data Warehouse (PDW)** menu, select **PDW File Extract Utility** to display the PDW File Extract Utility screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the **Design ID** field, enter the design for which you want to define selection criteria.

3. Use the **Select Data** hot key to display the PDW File Extract Selection screen. The system populates the **Design ID** field with the ID from the PDW File Extract Utility screen.

4. In the **Selection Type** field, press **F10** and select one of the following selection types:

<table>
<thead>
<tr>
<th>Selection Type</th>
<th>Selection is built from...</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRD Only</td>
<td>Eclipse Product file dictionary items.</td>
</tr>
<tr>
<td>PDW Indexed</td>
<td>Indexed metadata items in the PDW Catalog.</td>
</tr>
<tr>
<td>PDW Non-Indexed</td>
<td>All metadata items in the PDW Catalog.</td>
</tr>
<tr>
<td>Synced</td>
<td>Eclipse Product file dictionary items or indexed PDW Catalog items that are syncd.</td>
</tr>
</tbody>
</table>

5. In the **Conj** column, enter the appropriate conjunction of **AND** or **OR**.
For example: If you enter **AND**, the item must meet both **Compare To** values. If you enter **OR**, the item can meet either one of the **Compare To** values.

**Note:** In the Conj column, *** indicates the beginning of the statement. For **PRD Only** types, you can only use the **OR** conjunction.

6. In the **File** column, if you entered sync as your selection type, then enter either **PRD** to select from the Eclipse Product File or **PDW** to select from the PDW Catalog.
   
   If you selected another selection type, then the system enters the file type in this column.

7. In the **Dict/Meta Item** field, enter the dictionary or metadata item to use for the selection.

8. In the **Op** field, press **F10** and select one of the following operators to apply to the statement:
   - **= Equal To**
   - **# Not Equal To**
   - **< Less Than**
   - **> Greater Than**
   - **<= Less Than or Equal To**
   - **>= Greater Than or Equal To**

9. In the **Compare To** field, enter the value to which the dictionary or metadata item needs to be compared.

10. Press **Esc** to apply the selection criteria to the Extract Utility and return to the PDW File Extract Utility screen.

    **Note:** If a dictionary item is able to be updated, use the **Column Data** hot key to enter properties for the dictionary item. A columned screen appears where you enter the property data.
Downloading PDW and Eclipse Data to an ASCII Formatted File

Once you have designed and built the extract file, you need to download the file to an ASCII formatted file. Use the Report Queue to complete the download.

To complete the download of an extract file into an ASCII formatted file:

1. From the System > Printers menu, select Your Hold Entries to display the Report Queue window.
2. In the Report Title field, select the extract file.
3. From the Tools menu, select Download to display the Windows Select File window.
4. Enter the path and name of the file to which to download the extract file.
5. Add the .txt extension to the file name.
6. Import the file into a Windows application that can read .txt files.
7. Exit the window.
Filtering PDW Data

The Filter Builder function helps you sort data upon importing, exporting, merging, and syncing.

For importing, when you import unique keys that might not be unique to only the vendor providing the data, such as vendor name, UCC number, or NAED#, use the Filter Builder screen to ensure that the import map ID is matched to the correct metadata item.

For exporting, merging, and syncing, use the Filter Builder screen when you need to filter your searches of the product database.

To filter PDW data:

1. From any of the following screens, use the Filter hot key to display the Filter Builder screen:
   - PDW Data Import Utility
   - PDW Mass Product Export
   - PDW to PDW Merge Utility
   - PDW/Eclipse Product File Sync Utility
   
   Note: If prompted, log on to the character-based system.

2. In the Data Element field, press F10 and select an indexed metadata item, such as Vendor Name.

3. In the Opr field, press F10 and select one of the following expressions to define the relationship between the data element and the Value entry.
   - = Equal To
   - > Greater Than
   - >= Greater Than or Equal To
   - < Less Than
   - <= Less Than or Equal To
   - # Not Equal To

4. In the Value field, enter the value to match what you entered in the Data Element field.
   
   The system populates the And field with the value OR to indicate the linking phrase between multi-conditional statements.

5. Repeat steps 3 and 4, as needed, to enter multi-conditional statements.

6. Press Esc to put the filter into effect and return to the screen from which you accessed the Filter Builder.
PDW Translate Statements

When defining an import layout or export layout, use translate statements to modify incoming or outgoing data elements in the Product Data Warehouse (PDW) to match required formats. For example, your trading partner might define dates in the MM/DD/YY format, where Eclipse stores dates in the MM/DD/YYYY format; or your trading partner defines the unit of measure of each as "each" where Eclipse stores the same unit of measure as "ea". The system translates the data to the new format before importing it into the PDW or exporting it from the PDW.

You can manipulate data using operations such as concatenation, adding, subtracting, and defining table-based conversions. You can also append literal text to data elements.

Translate and convert statements differ, as follows:

- Translate statements affect entire fields of data. Translate statements are commonly used on discount class, unit of measure, and UCC number data.

- Convert statements apply to single words within fields. Convert statements are commonly used on product descriptions.

Use translate statements to perform the following functions:

- Change data elements imported from vendor files or exported from metadata items into different formats or different values.

  For example, a vendor defines 10 price discount classes for a product and you store these values in the PDW Catalog, but you only define three price discount classes for that product in Eclipse. Before you update the Eclipse Product file, create translate statements that map each of the vendor’s 10 codes to one of the three Eclipse codes. Each time you export the designated vendor discount classes to the Eclipse Product file, the system translates the vendor values into the appropriate Eclipse values.

- Combine multiple data items in an electronic file into one MetaData item in the PDW or combine multiple metadata items into one field in the Eclipse Product file.

  For example, a vendor data file contains a 6-character vendor ID and a 5-character NAED number. You can use a translate statement to combine the numbers and store the combined 11-character number as the UPC code in the PDW Catalog.

- Add prefixes or suffixes to imported data elements or exported metadata items.

  For example, you can append the vendor catalog number to the product description as a prefix.

- Create file-validated metadata items. The value in the metadata item points to a file the system uses to turn vendor information into Eclipse information.

  For example, a metadata item can reference a file to translate a vendor ID or discount class into an Eclipse buy line or price line.
Creating PDW Translate Statements

Use translate statements to manipulate the data elements you are importing before storing the data in the PDW or manipulate the metadata items you are exporting before you update the Eclipse Product file.

Use the PDW Translation Table to:

- Translate imported data or exported metadata items into different formulas or values.
  For example, you can translate a data provider's units of measure to Eclipse units of measure.
- Combine elements in the imported data or add prefixes or suffixes to imported data elements.
  For example, you can combine the data provider's 6-digit vendor ID with the 5-digit NAED number for a product to create a UPC number. Or you might append a 6-digit prefix that identifies the vendor to a product's NAED number to create a UPC number.

To create a translate statement:

1. Display the import layout or export layout you are defining.
2. Select the item in the Data Identifier column for which you want to create a translate statement and use the Translate hot key to display the PDW Translation Table screen.
3. To create a translate statement that changes values, complete the following steps:
   - Press Alt+Insert to insert a blank line in the From Value column.
   - In the From Value column, enter the value you want to translate.
     The system displays the value in quotation marks.
   - In the To Value column, enter the translated value.
     The system displays the value in quotation marks.
   - Repeat the previous steps for each value you want to translate.
   - In the To Value column for the **Any Other Data** value, enter the translated value the system should use for any From Value other than the ones you have listed.
4. To create a translate statement that combines multiple data items or appends prefixes or suffixes to data items, complete the following steps:
   - Position the cursor in the To Value column next to an entry in the From Value column.
   - Use the Enter Formula hot key to display the Formula Builder screen.
   - Enter a formula that concatenates designated data provider fields or appends prefixes or suffixes to designated data provider fields.
   - Press Esc to save the formula and return to the PDW Translation Table screen.
5. Use the following hot keys as needed:

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find</td>
<td>Positions the cursor at the Find prompt, where you can enter a search value for locating an item listed on the screen.</td>
</tr>
<tr>
<td>Hot Key</td>
<td>Function</td>
</tr>
<tr>
<td>---------</td>
<td>----------</td>
</tr>
<tr>
<td>View All</td>
<td>Displays the PDW Conv/Trans Table screen, which displays all the convert statements and translate statements defined for...</td>
</tr>
</tbody>
</table>

6. Press **Esc** to save the statements and exit PDW Translation Table screen.
Creating PDW Convert Statements

Use convert statements to change the values of incoming or outgoing data elements in the Product Data Warehouse (PDW). The system converts the data values before importing them into the PDW or exporting them from the PDW.

Translate and convert statements differ, as follows:

- Translate statements affect entire fields of data. Translate statements are commonly used on discount class, unit of measure, and UCC number data.
- Convert statements apply to single words within fields. Convert statements are commonly used on product descriptions.

For example:

- A vendor provides the following description:
  
  KOH 2524L GRN OV TOILET SEAT

- You want to convert the description to:

  KOHLER 2524L GREEN OVAL TOILET SEAT

To create PDW convert statements:

1. Display an import layout on the PDW Import Maintenance screen or an export map on the PDW Data Export Maintenance screen.
2. Select the metadata item for which you want to create a convert statement and use the Convert hot key to display the PDW Conversion Table screen.
3. In the Search For Value column, enter the value you want to convert.
4. In the Replace With Value column, enter the converted value.

The following table simulates the entries for the Kohler example from the overview:

<table>
<thead>
<tr>
<th>Search For Value</th>
<th>Replace With Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>KOH</td>
<td>KOHLER</td>
</tr>
<tr>
<td>GRN</td>
<td>GREEN</td>
</tr>
<tr>
<td>OV</td>
<td>OVAL</td>
</tr>
</tbody>
</table>

5. Use the following hot keys as needed:

The system converts the description as shown above.

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter Formula</td>
<td>Displays the Formula Builder screen, where you can enter a formula for creating the converted value.</td>
</tr>
<tr>
<td>Find</td>
<td>Moves the cursor to the Find prompt, where you can enter text and locate the line item in the table containing that text.</td>
</tr>
<tr>
<td>View All</td>
<td>Displays all the convert and translate statements for the selected data identifier on the PDW Conv/Trans Table screen.</td>
</tr>
</tbody>
</table>
6. Press **Esc** to save the statements and exit the PDW Conversion Table screen.
Viewing All Translate and Convert Statements

Use the PDW Conv/Trans Table screen to view all the translate and convert statements defined for a selected item on a PDW import or export map.

To view all PDW translate and convert statements for a map:

1. Display an import layout or export layout.
2. Use the **Convert** hot key to display the PDW Conversion Table screen or the use the **Translate** hot key to display the PDW Translation Table screen.
3. Use the **ViewAll** hot key to display the PDW Conv/Trans Table screen.
   This screen displays in view-only mode.
Building PDW Formulas

Use the Formula Builder screen to enter formulas for creating new values in translate statements and convert statements.

To build a PDW formula:

1. Log on to the character-based system.
2. Display the Formula Builder screen in one of the following ways:
   • From the PDW Translation Table screen, with data entered in the From Value field and the cursor positioned in the To Value field, use the Enter Formula hot key.
   • From the PDW Conversion Table screen, with data entered in the Search For Value field and the cursor positioned in the Replace With Value field, use the Enter Formula hot key.
3. In the Data Element column, do one of the following to enter the first operand of the formula:
   • For an import:
     • Enter a text string. The system displays the text in quotation marks.
     • Press F10 and select one of the vendor data identifiers to include in the formula.
   • For an export:
     • Enter a text string. The system displays the text in quotation marks.
     • Press F10 and select a metadata item to include in the formula.
4. In the Oper column press F10 and select one of the following operations:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>:</td>
<td>Append.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>^</td>
<td>Make Upper-Case and Append.</td>
</tr>
<tr>
<td>+</td>
<td>Add.</td>
</tr>
<tr>
<td>-</td>
<td>Subtract.</td>
</tr>
<tr>
<td>/</td>
<td>Divide.</td>
</tr>
<tr>
<td>*</td>
<td>Multiply.</td>
</tr>
</tbody>
</table>
5. In the Data Elements column, enter the second operand of the formula, using one of the methods described in step 2.
   
   **Note:** You can repeat steps three and four, as needed, to create complex formulas.

6. Press Esc to save the formula and return to the previous screen.
Using PDW User-Defined Files

Use Product Data Warehouse (PDW) user-defined files to populate PDW Translation Tables in an efficient, maintainable, and reportable manner. Instead of maintaining elaborate translation tables in PDW Export Maintenance, the translation table can point to a user-defined file containing cross-reference information.

For example, you can use PDW user-defined files to translate a vendor ID or discount class into an Eclipse buy line or price line.

In Export Maintenance, replace the translation table setup by Step 5 in the procedure below.

- The key to the file (vendor number) equates to the translation table's From Value column.
- The data you are entering equates to the translation table's To Value column.

This process can be repeated, but always create dictionary items for as many values as necessary. One file can be used for many values.

To use PDW user-defined files with Mass Load:

1. From the Tools > Product Data Warehouse (PDW) menu, select PDW Meta Maintenance to display the PDW MetaData Maintenance screen.
   
   Note: If prompted, log on to the character-based system.

2. In the Key# (or New) field, enter a key number or description to display the metadata item to which you are attaching the user-defined file.

3. Attach the file to the metadata item.
   
   Each unique value in the listed metadata item is then created as the key to an empty record in the selected file.

   For example, if you create a metadata item for vendor numbers and you attach a user-defined file to it, then every unique vendor number becomes a record in the user-defined file.
   
   Note: Files created for I2 Edataflex or IDW are tied to the proper metadata items.

4. After creating the empty records in the file by attaching the file to the metadata item, create a dictionary item for the data you want to load into the file. Point this dictionary item at the file's attribute where the data should be stored.

5. Populate the file using Eclipse Mass Load.
   
   For example, use the vendor number as the key to a price line. Use Mass Load to import the price line into the record corresponding to its proper vendor number.
   
   Note: If you are populating the files created by the I2 data loads, make sure that the attributes you load with data are not the attributes being used by the data provided by the import.

6. Apply the file to an Export Map.

7. Export the data to the Eclipse Product File.
To apply a user-defined file to an Export Map:

1. From the **Tools > Product Data Warehouse (PDW) > PDW Export Maintenance** menu, select **PDW Data Export Maintenance** to display the PDW Export Maintenance screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the **Export Map** field, enter the ID of the map to which to apply the user-defined file.

3. In the **Eclipse Dictionary** column, select the dictionary item to be populated.

4. In the matching **PDW MetaData Item** column, enter the metadata item with which you want to populate the dictionary item.

5. Use the **Translation** hot key to display the PDW Translation Table screen.

6. Use the **Enter Formula** hot key to display the Formula Builder screen.

7. In the **Data Element** column, enter the dictionary item for the value you want to capture.

8. Press **Esc** to save the correct mapping and exit the screen.
# Provided PDW User-Defined Files

Eclipse includes the following user-defined files with Product Data Warehouse (PDW).

<table>
<thead>
<tr>
<th>Product Resource</th>
<th>File</th>
<th>Contains</th>
</tr>
</thead>
</table>
| All PDW compatible files | PDW.VENDOR.INFO             | • @ID - Vendor UCC#  
• VENDOR.NAME  
• VENDOR.SHORT.NAME  
• VEND.SN  
• DISC.CLASS  
• SUB.CLASS  
• LINE  
• BLINE |
| I2 EdataFlex           | PDW.I2.VENDOR.INFO          | • @ID - Manufacturer PIK  
• Attr 1 - Vendor Short Name  
• Attr 2 - Vendor Full Name  
• Attr 3 - Vendor UCC Number |
| I2 EdataFlex           | PDW.I2.VENDOR.COMM          | • @ID - Manufacturer PIK – Commodity Code  
• Attr 1 - Commodity Code Description |
| I2 EdataFlex           | PDW.I2.VENDOR.DC            | @ID - Manufacturer PIK – Legacy Discount Code |
| IDW                    | IDW.VENDOR.DC               | Starts out as an empty file so that you can determine its IDW data population. |

You can also create as many user-defined files, as necessary, using File Definition Maintenance.
Rebuilding Cache Records for PDW

When you receive new vendor data, you need to rebuild the following cache records:

- Price Sheet/Discount Class Cache
- Zone/Sheet Cache

Rebuilding Price Sheet/Discount Class Cache Records

Use the Rebuild Price Sheet/Discount Class Cache Utility to delete old price sheet formulas from the Eclipse Product file. For example, if a vendor gives you disks with new price sheets and discount classes, run this utility to update price sheets and discount classes in your Eclipse Product file.

**To run the Rebuild Price Sheet/Discount Class Cache utility:**

1. From the Tools menu, select Rebuild Price Sheet/Discount Class Cache to display the Rebuild Price Sheet - Discount Class Cache Record(s) screen.
   
   You can also access this screen from the Tools > Product Data Warehouse (PDW) > PDW Export Maintenance menu by selecting Rebuild Price Sheet/Discount Class Cache.

   **Note:** If prompted, log on to the character-based system.

2. In the Enter Price Lines field, enter all price lines that need their price sheets and discount classes updated. Leave this field blank to rebuild price sheets and discount classes for all price lines.

3. Use the Begin hot key to run the update or use the Schedule hot key to schedule the update, and exit the screen.

   If you have already scheduled the rebuild utility to run, use the Begin hot key to run the utility at the scheduled time.

Rebuild Zone/Sheet Cache in Meta File Utility

Use the Rebuild Zone/Sheet Cache in Meta File Utility to update zone and price sheet tables in your metadata files. For example, if a vendor gives you disks with new price sheets and zones, run this utility to update price sheets and discount classes in the metadata files.

**To run the Rebuild Zone/Sheet Cache in Meta File utility:**

1. From the Tools > Product Data Warehouse (PDW) > PDW Export Maintenance menu, select Rebuild Zone/Sheet Cache in Meta File to display the Rebuild Zone/Sheet Cache in Meta File prompt.

   **Note:** If prompted, log on to the character-based system.

2. Enter Continue to run the update and exit the screen.
Rebuilding the PDW Index

Use the Rebuild PDW Index Utility to rebuild the entire Product Data Warehouse (PDW) index. Use this function when you are updating an entire price line or a lot of products in order to save yourself the time of individually updating each metadata item for each product.

This utility could take one to two days to run depending on the size of the index. The PDW.INDEX file is not a traditional index, and you can rebuild it while requiring access to the file. We recommend you run this utility to rebuild the index at a time when you are less likely to be accessing the PDW data. As the rebuild processes, you will only be able to access the data that has actually been rebuilt.

To rebuild the PDW index:

1. From the Tools > Product Data Warehouse (PDW) menu, select Rebuild PDW Index to display the Rebuild prompt.
   
   **Note:** If prompted, log on to the character-based system.

2. Enter Continue to run the utility, rebuild the PDW index, and exit the screen.
   
   The Phantom notifies you once the Rebuild Utility is complete.
   
   **Note:** Press F12 to abort this process if you accidentally select this menu option.
Purging PDW Catalog Record History

If it becomes necessary, you can delete record history from the Product Data Warehouse (PDW) Catalog.

For example:

- The wrong data is imported. If an import of external data does not run properly, use the PDW Catalog Rollback Utility to delete the imported data.
- The file becomes too large. Because the PDW Catalog saves the data from each import and update, the file can become large. Use the PDW Catalog History Utility to delete the oldest data that no longer has any use.

To use the PDW Catalog Rollback Utility:

1. From the Tools > Product Data Warehouse (PDW) > PDW Purging menu, select PDW Catalog Rollback to display the PDW Catalog Rollback screen.
   
   Note: If prompted, log on to the character-based system.

2. In the PDW Load Date field, enter a load date that the system can use as a reference purge date when selecting the items to purge.

3. In the Delete Data Items field, press F10 and select one of the following date options for purging:

<table>
<thead>
<tr>
<th>Option</th>
<th>Purge</th>
</tr>
</thead>
<tbody>
<tr>
<td>On Date</td>
<td>Records from only the date entered in the PDW Load Date field.</td>
</tr>
<tr>
<td>Before Date</td>
<td>All records with load dates that occur on or before the date entered in the PDW Load Date field.</td>
</tr>
<tr>
<td>After Date</td>
<td>All records with load dates that occur on or after the date entered in the PDW Load Date field.</td>
</tr>
</tbody>
</table>

4. In the Prevent Complete Deletion? (Y/N) field, enter Y or N to indicate if you want the system to safeguard you against deleting all records for a product.

   For example: If you entered Before Date in the Purge Records field and N in the Prevent Complete Deletion? (Y/N) field, then all product records imported on or before the indicated date are completely deleted from the PDW Catalog.

   If you indicate Y in the Prevent Complete Deletion? (Y/N) field, however, the system saves the most recent record and deletes the rest of the records for the product. Then, you do not completely delete the information for that product from the PDW Catalog.

5. In the Only if Synced? (Y/N) field, enter Y or N to indicate if you want the system to delete only synced records from the PDW Catalog.

   For example: If you enter Y in this field, the system searches for and purges only those PDW records that are synced to an Eclipse Product File. You would delete only synced records in cases where you would no longer be updating the product, such as discontinued items.

6. In the Selection Options field, if needed, enter an indexed metadata item and a unique value to purge only that value from the PDW Catalog.

7. Use the Sources or Meta Items hot keys to enter a list of sources or metadata items to delete from the PDW Catalog.
8. Use the Begin hot key to run the purge and exit the screen.

To use the PDW Catalog History Utility:

1. From the Tools > Product Data Warehouse (PDW) > PDW Purging menu, select PDW Catalog History Purge to display the Purge PDW Catalog History screen.
   
   **Note:** If prompted, log on to the character-based system.

2. In the **Number of Versions to Keep** field, enter the number of the most recent versions of PDW Catalog records to keep in the PDW Catalog.
   
   For example: If you have five versions of PDW Catalog records and you want to delete the oldest two versions of the records, enter 3. The system deletes the oldest two versions and keeps the most recent three versions.

3. In the **Minimum Date to Start Purge** field, enter a date to indicate which records to purge, as needed. The system deletes all records loaded on or before the entered date, as well as, the record versions indicated in the above field.
   
   **Note:** You can enter 0 in the **Number of Versions to Keep** field and indicate a date from which to run the purge in the **Minimum Date to Start Purge** field. The system will delete all record history on and before the date entered. Be sure that you want all of this history deleted before running the utility this way.

4. Use the Begin hot key to run the update or use the Schedule hot key to schedule the update, and exit the screen.
Running the PDW Master Upload Utility

Use the PDW Master Upload Utility to build product records in the Product Data Warehouse (PDW) Catalog from product data in the Eclipse Product file.

Note: This function is not necessary in most PDW installations. Your Eclipse PDW installer will authorize the function if you need it.

You can run the utility from the following two screens:

- Product Maintenance
- PDW Catalog Search

To run the PDW Master Upload utility from Product Maintenance:

1. From the Maintenance menu, select Product to display the Product Maintenance window.
2. Enter the product record you want to use to build the PDW product record.
3. From the PDW menu, select Product Master Upload to PDW hot key to display the PDW Master Upload prompt.
   
   Note: If prompted, log on to the character-based system.

4. Enter Y at the prompt to run the load from the Eclipse Product File into the PDW Catalog, and exit the screen.

To run the PDW Master Upload Utility from the PDW Catalog Search screen:

   
   Note: If prompted, log on to the character-based system.

2. Use the Search hot key to display the PDW Catalog Search screen.
3. Use the PM Upload hot key to display the PDW Master Upload prompt.
4. Enter Y at the prompt to run the load from the Eclipse Product File into the PDW Catalog and return to the PDW Catalog Search screen.
   
   Note: If the product already has a record in the PDW Catalog, then the upload updates the PDW product record.

5. Press Esc to save changes and exit the screen.
Index

C
close statements, PDW
  creating ........................................ 88
  viewing ....................................... 90

E
Eclipse Product File Batch Update Reports .... 73

P
PDW (Product Data Warehouse)
  about ........................................ 1
  ASCII formatted files, PDW data
    download .................................... 83
    extracting .................................. 78
  cache records, PDW .......................... 95
  convert statements
    creating .................................... 88
    viewing ..................................... 90
  delimited records
    about ........................................ 12
    solving common issues ................... 15
    using in import layouts .................. 12
  export maps, PDW
    about ........................................ 53
    convert statements ....................... 88
  metadata items to dictionary items
    default map ................................ 54
    multiple to one ............................ 57
    one to multi-valued or multi-branched 59
  viewing sample data ....................... 61
  price elements to pricing basis names .... 63
  pricing override maps ..................... 65
  product override maps ..................... 56
  translate statements ...................... 86

exported data
  about ............................................ 53
  editing ........................................ 68
  file batch updates .......................... 66
  filtering ..................................... 84
  mass product exports
    defining ..................................... 74
    exporting ................................... 75
  pricing zones ............................... 63
  verifying exports
    Eclipse Product File Batch Update
      Reports .................................... 73
    price ....................................... 69, 71
    product ..................................... 68, 71
    workflow .................................... 7

extracting data, PDW
  about ........................................... 77
  defining selection criteria ............... 81
  downloading ................................ 83
  extracting ................................... 78
  pricing design ............................... 80
  file batch updates ......................... 66
  fixed records, PDW .......................... 12
    about ........................................ 12
    solving common issues ................... 15
  formulas, building ......................... 91
  I2 EDATA FLEX, PDW import ............... 23
  IDW catalog, PDW imports .................. 27
  import date stamps, PDW ................... 35

import maps, PDW
  about .......................................... 11
  convert statements ......................... 88
  defining layout ............................ 12
layout keys .............................................16
mapping data ...........................................16
pricing zones ............................................16
translate statements .....................................86
using fixed or delimited fields .........................15
imported data
about .....................................................19
comparing imports
about .....................................................34
running ....................................................35
selection criteria .......................................37
deleting ...................................................24
filtering ....................................................84
importing ..................................................20
importing i2 data ........................................23
previewing ...............................................22
unique imports
about .....................................................26
checking request status ...............................30
EDI request IDW ........................................27
FTP request IDW ........................................27
FTP request PDW update .............................31
I2 EDATA FLEX .........................................23
viewing .....................................................24
importing data, PDW
about .....................................................20
comparing ...............................................35
filtering data .............................................84
Preview Report ..........................................22
viewing import date ...................................24
mapping data, PDW exports
about .....................................................53
convert statements .....................................88
metadata items to dictionary items
default map .............................................54
multiple to one ........................................57
to multi-valued or multi-branched ......................59
viewing sample data ....................................61
price elements to pricing basis names ...............63
pricing override maps ..................................65
product override maps ..................................56
translate statements .....................................86
mapping data, PDW imports
about .....................................................16
convert statements .....................................88
defining layout ..........................................12
layout keys .............................................16
pricing zones ............................................16
translate statements .....................................86
using fixed or delimited fields .........................15
mass product exports
defining ..................................................74
exporting ..................................................75
master upload ..........................................99
master upload, PDW .....................................99
merging PDW records
about .....................................................39
filtering data .............................................84
merging ....................................................40
PDW to PDW Product File Merge Report
.........................................................44
searching for matches ..................................43
verifying matches .......................................44
metadata maintenance
about ..................................................... 8
attaching user-defined files ......................... 92
defining metadata items ........................... 9
override maps, PDW exports ....................... 56, 65
provided user-defined files ........................ 94
purging record history ................................ 97
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>quick sync .................................................................</td>
</tr>
<tr>
<td>rebuild</td>
</tr>
<tr>
<td>cache records .........................................................................</td>
</tr>
<tr>
<td>PDW index ...............................................................................</td>
</tr>
<tr>
<td>reports</td>
</tr>
<tr>
<td>Eclipse Product File Batch Update ...........................................</td>
</tr>
<tr>
<td>PDW Data Proofing ....................................................................</td>
</tr>
<tr>
<td>PDW Price Sheet Formulas .......................................................</td>
</tr>
<tr>
<td>PDW Product File Sync ................................................................</td>
</tr>
<tr>
<td>PDW to PDW Product File Merge ................................................</td>
</tr>
<tr>
<td>Preview .....................................................................................</td>
</tr>
<tr>
<td>setup</td>
</tr>
<tr>
<td>creating a PDW product template .............................................</td>
</tr>
<tr>
<td>setup requirements ....................................................................</td>
</tr>
<tr>
<td>syncing data ............................................................................</td>
</tr>
<tr>
<td>syncing records, PDW ..................................................................</td>
</tr>
<tr>
<td>about .......................................................................................</td>
</tr>
<tr>
<td>additional functions ..................................................................</td>
</tr>
<tr>
<td>filtering data ..........................................................................</td>
</tr>
<tr>
<td>PDW Product File Sync Report ..................................................</td>
</tr>
<tr>
<td>quick sync ...............................................................................</td>
</tr>
<tr>
<td>running a sync ..........................................................................</td>
</tr>
<tr>
<td>searching for matches ..................................................................</td>
</tr>
<tr>
<td>unsyncing ..................................................................................</td>
</tr>
<tr>
<td>verifying matches ......................................................................</td>
</tr>
<tr>
<td>translate statements</td>
</tr>
<tr>
<td>about .......................................................................................</td>
</tr>
<tr>
<td>creating ..................................................................................</td>
</tr>
<tr>
<td>viewing ....................................................................................</td>
</tr>
<tr>
<td>unsyncing products, PDW ................................................................</td>
</tr>
<tr>
<td>verifying exports, PDW ............................................................</td>
</tr>
<tr>
<td>Eclipse Product File Batch Update Reports ..................................</td>
</tr>
<tr>
<td>price .......................................................................................</td>
</tr>
<tr>
<td>product ....................................................................................</td>
</tr>
<tr>
<td>workflows</td>
</tr>
<tr>
<td>data flow ..................................................................................</td>
</tr>
<tr>
<td>from import to export ..................................................................</td>
</tr>
<tr>
<td>PDW catalog, deleting items ....................................................</td>
</tr>
<tr>
<td>PDW catalog, editing ...................................................................</td>
</tr>
<tr>
<td>PDW catalog, viewing ...................................................................</td>
</tr>
<tr>
<td>PDW Data Proofing Report about ..............................................</td>
</tr>
<tr>
<td>comparing data ..........................................................................</td>
</tr>
<tr>
<td>defining additional criteria ....................................................</td>
</tr>
<tr>
<td>PDW Price Sheet Formulas Report ..............................................</td>
</tr>
<tr>
<td>PDW Product File Sync Report ..................................................</td>
</tr>
<tr>
<td>PDW to PDW Product File Merge Report ........................................</td>
</tr>
<tr>
<td>preview product records, PDW import ........................................</td>
</tr>
<tr>
<td>Preview Report ...........................................................................</td>
</tr>
<tr>
<td>pricing zones, PDW ....................................................................</td>
</tr>
<tr>
<td>defining in exports ....................................................................</td>
</tr>
<tr>
<td>defining in imports ....................................................................</td>
</tr>
<tr>
<td>product records</td>
</tr>
<tr>
<td>PDW .........................................................................................</td>
</tr>
<tr>
<td>creating ..................................................................................</td>
</tr>
<tr>
<td>date stamps ...............................................................................</td>
</tr>
<tr>
<td>deleting items ..........................................................................</td>
</tr>
<tr>
<td>editing .....................................................................................</td>
</tr>
<tr>
<td>merging .....................................................................................</td>
</tr>
<tr>
<td>Preview Report ..........................................................................</td>
</tr>
<tr>
<td>search matching records ..........................................................</td>
</tr>
<tr>
<td>sync utility ...............................................................................</td>
</tr>
<tr>
<td>updates .....................................................................................</td>
</tr>
<tr>
<td>viewing .....................................................................................</td>
</tr>
<tr>
<td>purging</td>
</tr>
</tbody>
</table>

© 2011 Epicor Software Corporation. All rights reserved.
<table>
<thead>
<tr>
<th>R</th>
<th>S</th>
<th>T</th>
</tr>
</thead>
<tbody>
<tr>
<td>rebuilding cache</td>
<td>syncing records, PDW</td>
<td>translate statements</td>
</tr>
<tr>
<td>PDW records</td>
<td></td>
<td>about</td>
</tr>
<tr>
<td></td>
<td></td>
<td>creating</td>
</tr>
<tr>
<td></td>
<td></td>
<td>viewing</td>
</tr>
<tr>
<td>rebuilding indexes, PDW</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>reports, PDW</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Eclipse Product File Batch Update</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PDW Data Proofing</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PDW Price Sheet Formulas</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PDW Product File Sync</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>